Did I Kill My Diecimila?

I removed from my Diecimila the original ATmega chip and replaced it with a different one. When I plugged the Dieci in, the TX/RX LEDs flickered a bit, then after 60 seconds the LED marked "L" began flashing constantly and no comm port was created. I put the original chip back in and it does the same thing. I know it isn't an orientation problem - the notch in the chip is aligned w/ the notch in the socket (as a sanity check, I reversed the chip; no flickering LED, but still no comm port created). I also know it isn't a PC problem as my other Diecimila works perfectly; comm port 18 is created, sketches load.

Did I kill it?

Any recommendations as to what I should try in order to revive it?


You can try to plug it in without the chip on the board. placing the atmega168 with a wrong orientation can kill the atmega, but not the USB chip. Was the board on when you replaced the atmega?

What instruments do you have? Oscilloscope? Multimeter?

It wasn't powered up when replacing the chip. I have number of multimeters, an L/C meter, will soon have an M3 Semiconductor Analyzer, but no oscilloscope (yet; had the opportunity to pick up -- virtually for free -- several old but perfectly good bench PSUs, bench multimeters, and o'scopes when working as a technician for Dominion Telecom & moving the lab from Ashland to Richmond VA, but I didn't think I'd ever use 'em. Good gawd that was stupid!).

Have you fixed it? If not was that replacement chip one that had a Decimilla bootloader on it?

Nope, haven't fixed it yet (holiday goings-on). The replacement ATmega was a new blank. I just pulled the uC and plugged it in, but there was still no port created; it was listed as an unknown device.

Hmm, if no serial port is created when you plug in the board, it sounds like there's a problem with the FTDI chip or power supply. Do you have the power selection jumper on the two pins closest to the USB port? Does the power LED go on right away when you plug in the board? What operating system is the computer running? Can you try plugging the board into another computer?

I built a Boarduino this morning and tested the Diecimila’s ATmega – it doesn’t do a thing. The Boarduino chip works fine in the Diecimila. Perhaps I cracked the chip whilst removing it the first time or there was enough residual juice in the caps that it shorted some pins & corrupted the bootloader?

Not a big deal as I have dozens of replacements; just have to get the bootloader on 'em which is no big deal either. I’ll probably use the bad chip first…

Thanks for all the help!

my atmega168 no longer boots :( i carefully removed it to do some re soldering work on some pins and it would not boot at all when i plugged it back in :(

could the chip be dead or just the bootloader corrupt.. if so can it be fixed if u try and reload the bootloader using the parallel cable (yet to build)

My board itself seems fine, it connects to my pc and powers up ok. When i try to upload a sketch to it the Rx led blinks a little and the prog says it cannot do it.. there is no tx light at all or pin 13 light.

it was put in isolated from power, the correct way round, and all pins unbent and correct..

any ideas? i have no other board to test the chip with or another atmega to test the board with (this is my 1st arduino).

anyone? :(

i’m sorry for you. if all connections are fine and you did not mess up with the soldering, there’s probably something wrong with the atmega. i don’t know if this should happen or how it happens, but probably just the bootloader got lost or blocked. this happened like 3 times to me, while switching boards (a million times). since the parallel cable wouldn’t work on a mac i bought a mkII with usb.

those 3 atmegas8 and 168 could easily be recovered by burning a bootloader again. if the parallel cable is an option for you, go for it. if you plan to do more with arduino you’ll appreciate to be able to burn your own bootloaders on 3euro raw atmegas.


i'll happily try and burn a new bootloader. if u had the right resistors to make the cable :D i have no 470 ohm resistors so its not going to be easy :S

can i get away with putting some in series or something to get 470, or if i cant get 470 how close do i have to be?

i have no 470 ohm resistors

Do you have 1k? Put two of them in parallel and you've got 500ohms, more than close enough to 470 to work.

Once upon a time I threw together a little perl script that took all the resistors I had on had, combined all possible permutations of two in parallel and two in parallel/one in series. wonder what I did with that one?


1 k in parallel huh? thnx :) i'll look into that then. i hope its enough :D and i hope i gots 4 of them :)

made cable with 2 500 ohm resistors i managed to find..

but not having much luck

the arduino IDE option for programming a new bootloader said it couldnt find the chip, and uisp gave this when i added -v at the end of the command line cos it was saying all was hunkydory when it wasnt :

AVR Direct Parallel Access failed after 32 retries.
Atmel AVR ATmega168 is found.
Erasing device ...
Reinitializing device
AVR Direct Parallel Access failed after 32 retries.
Atmel AVR ATmega168 is found.
Uploading: flash
(total 1818 bytes transferred in 1.42 s (1278 bytes/s)
Polling: count = 15, min/avg/max = 13.00/13.73/14.00 ms

so im not sure if its XP (i stopped polling on lpt), the board, or the chip.. i need another atmega to test really. or another board. both would be good.. im hoping to be getting something in the post soon. fingers crossed.

can someone make up a schematic of a direct to chip breadboard version of the parallel programmer? omitting the arduino board, so u have a dedicated parallel programmer for such cases as this? :)

(edit) I have tried to use isp programmer from http://www.amwaw.edu.pl/~adybkows/elka/ispprog.html as mentioned in this thread: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1142106610

i have managed some communication with it but wont upload to flash and a verify gives the same response

write error at address 00003800 byte in file :0C byte read: FF

when i try and read and write to th eeprom it seems to work.. but thats not helpful without the flash is it?

you should try Brian Dean's Programmer (bsd). it comes with avrdude and UISP and the pin outs are on the website.


Its got me out of a tight squeeze on many an occasion and is extremely easy to set up. check it out :).