Diecimila and Processing Arduino class

Hey all,

I am working with the Arduino class for Processing. It works fine when I use my Arduino first gen, but all of the same software does not work when I use the Diecimila. The problem seems to be in the Processing class, since I can use both Arduinos with the exact same Firmata version with the Pd object.

Any ideas as to the source of this?



We have a similar issue. Standard_Firmata_334 (from http://www.arduino.cc/playground/Interfacing/Firmata) works fine from within Processing 0132 with old generation Arduinos and Barebone Arduinos, but not with the newer Diecimila boards.

Arduino version 010 on both Mac Intel and PC

Any suggestions or directions would be appreciated.

Thanks in advance.


I took a quick look at this, and it seemed the Diecimila was resetting in the middle of connection, which is very strange. I'll have to dig deeper in it.

Hi @all, i just found that solution here : http://itp.nyu.edu/physcomp/Fall07Shakar/TomsNoteAboutSerial

BUT: its not working with Arduino Library for Processing (and Firmata) from the playground section.

any idea ???


You have to edit the Arduino.java like in this email:


Hi all,

I'm still experiencing issues with Diecimila boards and Processing. Anyone has a working solution/setup on their site?

I've tried with the files and instructions for this Playground page: http://www.arduino.cc/playground/Interfacing/Processing

and the Arduino.java modification seems to be in the latest Processing version...

BTW, all my sketches are working just fine with NG and BareBone boards. Too bad we can't use our Diecimila boards for this...

Thanks in advance,


Huh, it worked when I tried it. What operating system are you on? What problems do you have?

whoa... ignore below -- i just redownloaded the original link from the wiki and had no problem; will delete my entry there.

as far as i could tell the revision wasn't in the latest processing library (at least as downloaded from here: http://www.arduino.cc/playground/Interfacing/Processing ); so i've made the revision and a new .jar and uploaded a 2nd version of the library (also uploaded to that page) for those who have difficulty. this has been tested on my mac and using a diecimila which was giving me trouble and it seems to work.

(mellis, please feel free to change my entry on the arduino wiki if you think it confuses the issue to have 2 different libraries...)


I'll give it a try tomorrow for sure, I've been bumping my head on this one for a long time.


Hi again,

sorry but still the same problem. The Diecimila doesn't react at all. It's getting the command (blinking Rx led) but nothing alive past this on the digital pins. I'm using the arduino_output example file.

I downloaded the Arduino.jar (dated Nov 15th 2007) from http://www.arduino.cc/playground/Interfacing/Processing

I'm on Mac OS X 10.5.2 (MacBook Pro, 2.2Ghz, 2GB ram) with Arduino 0010 and Processing 0135. In Processing:

Native lib Version = RXTX-2.1-7 Java lib Version = RXTX-2.1-7

If I upload the same firmata code to a NG or BB board, it just works.

Any clue or tips that may help get the duo Processing + Firmata/Diecimila working.

Thanks a lot,


If upload, say, the Blink example to the Diecimila and reset it, how long of a delay is there before the sketch starts? Some of the Diecimila boards were accidently burned with the wrong bootloader (that has a ~7 second delay instead of ~2 seconds).

The Diecimila boards we have take ~7 seconds to start after reset. I guess that is the source of our problem, as the Processing Arduino class waits for 2 seconds:


I just burned a new bootloader on one of our Diecimila boards and it now works! Lovely :-) Thanks a lot for the help. It's really appreciated.