Diecimila and Ubuntu 8.04

Being the glutton for punishment that I am, I decided to try programming the Diecimila on Ubuntu linux. I had gotten things working under winxp.

Error: avrdude: stk500_recv(): programmer is not responding avrdude: stk500_recv(): programmer is not responding

Has anyone gotten Arduino working with this hardware/software? Note: /dev/ttyUSB0 selected. Have tried pressing reset before/during/after programming without effect.

My config: Bare bones board from from Modern device. Ftdi usb to serial cable. Ubuntu 8.04.

I followed the instructions on http://www.arduino.cc/playground/Linux/Ubuntu

Also, see my Ubuntu post also: http://ubuntuforums.org/showthread.php?t=815538&highlight=arduino

Have you tried asking in the Modern Device forum?


Paul Badger replied that he had limited knowledge about Linux so he could not help.

In any case, there is a development.

I was able to make it [u]work some of the time[/u], by holding releasing the reset button at the same time as I hit the Upload button on the ide. This is a workaround.

I would like to direct this item to your attention and Paul's attention: http://www.ladyada.net/forums/viewtopic.php?t=4703

Basically, under Win, Port settings must be adjusted using "Set RTS on Close". If you don't do this, you can only program the first time or after unplugging the USB cable.

Under Ubuntu 8.04, the behavior is identical (but of course, you can NOT change the port setting the same way, I believe. )

He goes on to say that a change is required to the RXTXComm package that Arduino uses. See the link for full details.

Could someone take a look at this? I think that possibly a change to the Arduino environment would be helpful.

Thanks, Steve.

This serial port issue is an annoying problem and it would be nice to get this fixed.

Let me summarize the problem. The Diecimila uses the DTR line for reset signaling. The FTDI cable does not have that signal available and uses the RTS line for signaling, which on the Mac, seems to follow the DTR line.

Somewhere in the serial port handling of the Windows and Linux version of Arduino though, the RTS line does not seem to follow the DTR line. The "set RTS on close" serial port setting seems to counteract the differences in the Arduino software.

It looks like a fairly simple fix has been figured out, but the details of the mod are not exactly clear to me. I'd bet the user that figured it out would be delighted to see his fix get implemented.

Any chance on getting this fixed Mellis? I'll be glad to test code.


I'm afraid I didn't quite understand the post on ladyada's forum. In particular, the poster didn't really explain how what he did affected the RTS line, which, is, I think, how the reset works on the Boarduino. Also, I believe that setting HUPCL will disable assertion (lowering) of DTR when the port closes, preventing the auto-reset on the Diecimila, for example, from working more than once. Can you do any further investigation into how this works and its effects on the Diecimila and BBB? Also, note the behavior can vary across Mac, Linux, and Windows, so you probably want to test on all three platforms.

Thanks Mellis,

I'll pursue this further and maybe post it to software bugs forum when I have something more definite. I couldn't really parse out what was going on in particular either but thought it might just be serial port programming with which I am totally unfamilar.


Cool, thanks.

These things do tend to be rather mysterious, so I'd like to have a well-understood and tested approach before changing anything.

Hi Optique,

Just got my Arduino Nano, and tried it out on my Ubuntu 8..04 system. It worked fine after I followed the instructions on the Arduino Playground, Linux section. As it turned out, Java JRE 1.5 was already installed on the machine and only needed to be selected; but everthing else went as expected.

The only anomaly I've found so far is that the Arduino IDE spits out a couple of errors when it starts up. Haven't explored this much as yet, but it happens on both the Windoze and Ubuntu machines, so it would seem to be part of the Arduino stuff. I can't explain why you get errors about the STK500 -- have you checked all the settings in the IDE to make sure it's set for the correct comm port (dev USB0 on my machine), etc ? ? ?

Good luck


Did u remove Braille termial package already? (brltty), after Ubuntu 7.10, you need to remove brltty before using FTDI device.. by command on terminal

sudo apt-get remove brltty

running diecimila or nano on my ubuntu 8.04 environment

only running on vista needs lot of patience, thats why i boot my Lenovo N200 with Hardy Heron

I am converting over from mac OSX to UBUNTU Karmic and the same problem was driving me batty. Finally this thread gave me the hint to go back to old school style "press the reset button as you upload" and that works for me on my ubuntu machine. Annoying, but workable. I look forward to a resolution on this.