Diecimila + SeeedStudio Ethernet v1.0

I bought this ethernet shield a couple of years ago. I'm trying to make it work but had no success after a few hours.

Some of the scenarios I've tried is using the provided sketch for WebServer setting up an IP address on the same network as my computer (connected with a cable, no routers or hubs) I've used the following sketch (Arduino Ethershield · GitHub).

When I reset (or power up) the arduino, I only get a message "server is at" on the serial monitor. As if, for some reason the ip could not be configured.

I've tried to change the mac address with no success.
I've tried using an external power source also with no success.

I'm using an arduino diecimila and a Ethernet Shield v1.0 by Seedstudio.

Any help would be great.

Sounds a bit like there's not communication to the WizNet5100 chip. How are the jumpers for the SPI communication set? Can you check the electrical connectivity for the SPI pins (10, 11, 12, 13)?

connected with a cable, no routers or hubs

What happens if you set the Arduino up with an IP address reserved in the router for the IP and connect the Ethernet shield to the router as it was intended to be connected?