Difficulties with uploading. Error : avrdude: stk500_getsync(): not in sync: res

Okay, so I fried the Atmega328-PU on my Arduino Duemilanove clone board a couple of days back and ordered a new one with the Arduino Bootloader already loaded into it. It came it today, and I plugged it in the board. It had the Blink sketch preloaded into it, so LED began to blink.
The problem began AFTER I installed all the drivers, the Arduino got detected on COM3(always has been detected on COM3 previously as well), but I cannot upload anything to the board. Made a few observations. Here they are :

  • Atmega is plugged in the right direction.
  • I've chosen the correct port and board, so no problems there.
  • While trying to upload the sketch, the Rx blinks, the Tx doesn't.
  • The serial-loopback test works, so its not the FTDI chip that's screwed.
    (Read somewhere that LED 13 not working means your bootloader is corrupt. )
  • LED 13 doesn't blink when I press the Reset Button.
  • LED 13 blinks 3-4 times when I power up the board every time.
    (Okay, the bootloader might still be corrupt.)
  • BUT, here's the strange thing. I kept the board on for a while, and SUDDENLY LED 13 TURNED ON. JUST LIKE THAT! Totally random. Stayed on for around 10 secs. Then turned off.
  • Re-installed drivers and tried again. Still no luck. Same mysterious LED 13 behaviour.

So, here are my observations.
What am I doing wrong? How can I fix it?
Also, could zapping the any of the pins with (maybe) a little bit of static cause this?
Read something about the XTAL pins being extremely sensitive to static, which would mess up the clock, which would explain the erratic timing and failure in communication. Could this be the case?
Any and all help is appreciated. :slight_smile:

What bootloader was installed on that 328? That determines what board you need to select in the IDE.

If it came with the Optiboot bootloader, then you would need to select UNO, for example.

Selected the UNO and tried uploading. Still no luck.