Digital servo problems

Hey arduino people,

I recently received a Hitec HS-7950TH found here http://www.servocity.com/html/hs-7950th_servo.html

  • When I hook it up to my Futaba R/C receiver it works fine, but when I connect it to my arduino pro mini it just makes a clicking noise.
  • When I run a program it doesn't move and won't hold position.
  • If I plug in an analog servo the same way that servo works just fine.
  • I am using a 36W 7.4V DC/DC converter to power the servo and arduino pin #3 for controlling.
  • I am using the default sweep sketch for control.

Any ideas? I went ahead and ordered a programmer, that will be here in a few days.

So how exactly have you connected it and where is your code? Can't guess these things you know....

MarkT:
So how exactly have you connected it and where is your code? Can't guess these things you know....

Well, you can always guess. I'm going to guess either:

  1. There's a giraffe sitting on the servo.
  2. There's no connection between the arduino GND and 7.2V supply GND.

There's a giraffe sitting on the servo.

How do you know its a giraffe rather than a zebra?

The Pro Mini comes in 2 versions 5v and 3.3v. If you have the 3.3 one I bet that digital servo likes to see a pulse with at least 4.5v oomph at least that is what the specs say on the page you linked.

Your digital servo works with the futaba because it has the correct voltage.

Your analog servo works because most analogs one are ok with the 3.3v signal.

This is just guessing that you do have the 3.3v version.

Thank you for the comments, especially the giraffe one, but the problem was solved with a 10 ohm resistor on the 7.4V rail going to the servo.

I noticed that the servo would work when I used test leads instead of directly soldering the servo in. So I guessed it had to do with the resistance of the leads, so I experimented and a resistor on the power rail fixed the issue. It would be great if someone could explain this, because it isn't a voltage issue, I had the servo running at 7.8V at one point, and my DC/DC converter was sourcing 7.44V (tested with a fluke)

Why does it work?

From Service Bulletins | HITEC RCD USA

HS-20110524 HS-7940/7945/7950TH Jumping/Glitching

In some cases, when using the 7940/45/50's in applications that require a very long extension, they may randomly jump (glitch) when powered by 2S LiPo/Li-Ion batteries. Although this may occur with many systems, it is most commonly found when using JR/Spektrum type RX's, especially the Power Safe versions. We have discovered that due to the resistance in long extension wires, the signal voltage drops, thus causing the issue. We recommend that only high-quality, twisted, 22-guage, high strand count, gold connector extensions be used. In the event that this does not resolve the problem, there are a few options. The use of a signal line booster like that made by Spektrum, and soon to be available by Hitec, resolves the issue in almost all cases. Another option is to solder a .22 tantalum capacitor between +/- on the extension. These solutions are typically only needed when using Li-Po/Li-Ion batteries to lower the voltage below 7 volts and is not needed when using 5-cell NiCd/NiMH or LiFe batteries.

We are aware that these are high voltage servos designed to operate at the maximum voltage allowed for maximum performance. However, to accommodate some radio systems, steps may be required to assure the above issue will not occur. Hitec apologizes for any inconvenience this may cause and is working on a series of new Ultra Heavy Duty extensions (with and without boosters) that will resolve this issue.

Doesn't make a lot of sense why the tantalum capacitor would help the problem, but sounds like you have a 7.4V rated servo that doesn't run at 7.4V reliably.