dimmer une lampe 12 volt avec un mosfet

Bonjour à tous,
j'essaye de dimmer un gyrophare 12v. J'ai séparé la lampe et le moteur, mais dans les deux cas le même soucis...

J'utilise le module mosfet adafruit

que j'agisse sur la lampe ou le moteur j'ai le même problème: il y a un bruit électrique quand je suis dans la fourchette de gradation... ce bruit disparaît lorsque je mets aux bornes du mosfet le 5volt provenant du pwm de l'arduino, et du coup il y a 12 volts aux bornes de la lampe.

Il y a plein de tutos là-dessus mais je ne comprends pas pourquoi chez moi, il y a ce bruit qui apparaît...

Peut être un problème d'alimentation ? Qu'en pensez-vous ?

Merci à tous par avance.
gundorf

bonjour,
une photo des branchements serait bien.
le bruit vient du mofset ou du moteur?

merci d'avoir répondu :slight_smile:
le bruit vient du moteur...
je vais faire une photo oui...
j'ai entendu parlé de la fréquence du pwm qui pouvait s'entendre...Est-ce possible ?

gundorf:
merci d'avoir répondu :slight_smile:
le bruit vient du moteur...
je vais faire une photo oui...
j'ai entendu parlé de la fréquence du pwm qui pouvait s'entendre...Est-ce possible ?

bonjour
Le PWM "peut" s'entendre sur un moteur , generalement en "bas du pwm" :sunglasses: , il s'agit de l'entrée en resonnance du moteur à la limite de la mise en rotation.
Le taux de PWM nécessaire pour commencer à faire tourner un moteur est (quasi) toujours superieur au taux de PWM d'un moteur en rotation pour s'arreter.
le sifflement est perceptible avec un moteur CC à collecteur, mais surement pas avec seulement une lampe.