display epaper 1,54 inch, problemi compilazione

Ciao a tutti: Come da oggetto. Ho acquistato questo displayino per utilizzi al aria aperta visto il suo perfetto contrasto. Non c'è quasi nulla in rete a riguardo. Ho trovato solo questo tutorial tra wave share e youtube:

https://www.waveshare.com/wiki/1.54inch_e-Paper_Module#Introduction

https://www.instructables.com/id/Getting-Started-With-E-Paper-Display-Modules/

Ho iniziato con quello della waveshare, collego tutto come da manuale, ma mi da errori di compilazione appena faccio una verifica.

Vedrò di incollare qui nel forum i messaggi di errore...

Non so se abbia a che fare col IDE, io ho istallato un IDE molto vecchio perchè l'ultimo non mi lascia istallarlo e non so perchè, mi da molti errori in fase di istallazione e poi non si lancia nemmeno, neanche riavviando il pc. Ma quello che hoistallato con tutti gli altri sketch fatti fino ad oggi non da nessun problema.

Qualcuno può verificare per piacere se il codice di waveshare e`corretto o se c'è qualcosa che non va? Di già vi ringrazio.

Se qualcuno ha utilizzato in passato questo display comandato in SPI lo ringrazierei molto se mi darebbe delle dritte con delle risorse per pilotarlo. Purtroppo in rete non trovo nulla.

Saluti,

Gustavo

  1. che sistema operativo usi
  2. che versione esatta del IDE
  3. il link al codice che cerchi di compilare
  4. i messaggi di errore (… cortesemente, racchiusi tra i tag CODE che, in fase di edit, ti inserisce il bottone </> … primo a sinistra)

Grazie,

Guglielmo

P.S.: E comunque, prima di usare quel dispaly, ti sei studiato bene il manuale d’uso come raccomandato sul sito?

Non c'entra con l'errore che segnali, ma ... hai letto che quel display NON può essere alimentato per troppo tempo a 5V? Stai utilizzando dei traslatori di livello tra i segnali a 5V ed i pin di quel display che lavorano TUTTI a 3.3V?

1.54inch-e-paper-module-4_1_1.jpg
Guglielmo

1.54inch-e-paper-module-4_1_1.jpg

gpb01:

  1. che sistema operativo usi
  2. che versione esatta del IDE
  3. il link al codice che cerchi di compilare
  4. i messaggi di errore (… cortesemente, racchiusi tra i tag CODE che, in fase di edit, ti inserisce il bottone </> … primo a sinistra)

Grazie,

Guglielmo

P.S.: E comunque, prima di usare quel dispaly, ti sei studiato bene il manuale d’uso come raccomandato sul sito?

Ciao! Provvedo a detagliare tutto, intanto:

Sistema operativo windows XP ue7

IDE 1.0.6

Non c’è un link al codice ma un file zip da scaricare e scomprimere, vedro’ di scaricarli e incollarli su messaggio.

Il voltaggio di alimentazione si l’ho fatto a 3,3V come indicato ma mi da errore di compilazione con e senza arduino connesso…

Grazie

Gustavo74: Il voltaggio di alimentazione si l'ho fatto a 3,3V come indicato ma mi da errore di compilazione con e senza arduino connesso...

Nell'attesa del codice ... NON basta l'alimentazione a 3.3V, occorre inserire gli adattori di livello su TUTTI i pin di I/O. :)

Guglielmo