Display LCD Errore

Salve, a tutti,
premetto che sono un novello di arduino e sto muovendo i primi passi.

Ho acquistato un display LCD e ho seguito diversi tuttorial per il funzionamento, sono tutti molto simili, solo che con tutti non riesco a far stampare nulla sul diplay, la prima riga è completamente vuota, mentre la seconda tutti quadratini neri. Non credo che il problema sia la risoluzione in quanto variando il potenziometro non riesco comunque a vedere la prima linea.

Ecco il codice che ho utilizzato

#include <LiquidCrystal.h>
 
// initialize the library with
// the numbers of the interface pins
LiquidCrystal lcd(12, 11, 5, 4, 3, 2);
 
void setup() {
  // set up the LCD's number of columns and rows:
  lcd.begin(16, 2);
  // Print a message to the LCD.
  lcd.print("hello, world!");
}
 
void loop() {
  // set the cursor to column 0, line 1
  // (note: line 1 is the second row,
  // since counting begins with 0):
  lcd.setCursor(0, 1);
  // print the number of seconds since reset:
  lcd.print(millis()/1000);
}

Penso che il display possa essere rotto, ma da neofita non so come fare una diagnosi.

Grazie
e complimenti per il bellissimo forum!

Dato che non ti sei ancora presentato, non so se sei esperto con il saldatore... Lo stagno mi pare appena accostato ai pin della stripline... Ripassa bene tutte le saldature i pin devono essere ben circondati dallo stagno.

Per cortesia: 1- passa nella apposita sezione QUI e presentati, magari specificando anche quali conoscenze hai di elettronica e programmazione. 2- leggiti il regolamento del forum QUI

Attilio

Presentazione effettuata :)

Grazie marinaio67 per la risposta, ho rivisto tutte le saldature del display (saldature originali, non fatte da me), ma i contatti sono funzionanti.

Uhmm.. a vedere dalla foto sembra che i collegamenti non sono giusti, per esempio il pin 11 di arduino va al pin 6 (enable lcd), ma tu hai collegato il pin 12 di arduino al 6 lcd ,mentre dovrebbe essere il pin 11 (che non hai collegato), collegato al 6 dell'lcd, e il poi 12 collegato al 4 dell'icd.... ci sono vari errori ricontrolla bene.

|500x356

edit: dalla foto è anche collegato il 13 pin di arduino che non va collegato almeno dallo sketch che usi.