Display LCD

Buongiorno a tutti.
Sono sicuro che sto annegando in un bicchiere d'acqua ma...
Stavo provando un circuito ed ho voluto inserire un display LCD ma mi mostra solo la prima riga con tutta l'area carattere illuminata e nient'altro.
Ho provato con lo sketch HelloWorld con il medesimo risultato. Ho cambiato LCD, ho cambiato scheda Arduino e il risultato è sempre lo stesso e non scrive mai sulla seconda riga.
Cosa può essere ?!?

Franco

sketch please..... :slight_smile:

hai provato a regolare il contrasto?

Grazie per l’intervento, ecco lo schetch

transmitter_2_LCD.ino (2.02 KB)

ORSO2001:
hai provato a regolare il contrasto?

:slight_smile: si l'ho fatto :slight_smile:

non centra con il tuo problema ma perchè gli ultimi 4 li hai invertiti rispetto ai commenti?

// LCD pin: RS (A5), E (A4), D4 (A3), D5 (A2), D6 (A1), D7 (A0)
LiquidCrystal lcd(19,18,14,15,16,17);

e non:
LiquidCrystal lcd(19,18,17,16,15,14);

i collegamenti sono come questi?

lcdTest_bb.jpg

Patrick_M:
non centra con il tuo problema ma perchè gli ultimi 4 li hai invertiti rispetto ai commenti?

// LCD pin: RS (A5), E (A4), D4 (A3), D5 (A2), D6 (A1), D7 (A0)
LiquidCrystal lcd(19,18,14,15,16,17);

e non:
LiquidCrystal lcd(19,18,17,16,15,14);

i collegamenti sono come questi?

Perché non so più cosa fare!!! e ho salvato senza ripristinare. :confused:

collega solo l’lcd ad arduino e carica uno dei programmi di esempio tipo hello world e poi vediamo :slight_smile:

Patrick_M:
collega solo l'lcd ad arduino e carica uno dei programmi di esempio tipo hello world e poi vediamo :slight_smile:

Con un nuovo Arduino UNO e collegamento diretto ora funziona... :confused:
Per gli esperimenti uso una bredboard Arduino Proto Shield Plus v3 e temo di averla seviziata troppo >:(
Forse è lei a non funzionare. Continuerò le verifiche.
Grazie per il vostro tempo ma ci risentiremo presto nella sezione software... :slight_smile:

Franco