Display verläuft

Morgen, ich hab meine Wetterstation jetzt soweit fertig das ich sie Testen kann. Jedoch macht mir mein Display Probleme. Je nach Versorgung verläuft das Display, wenn ich mit dem Display etwas zB. IP-Adresse Einstellen will. Beim Mainprogramm das läuft (Loop) das verläuft nie.
Wenn ich es per USB Versorge kein Verlaufen, Netzteil wenig und dem Eigentlichen Schaltnetzteil verläuft es viel.

Schaltnetzteil: https://www.conrad.de/de/steckernetzteil-einstellbar-voltcraft-sps24-48w-9-vdc-12-vdc-135-vdc-15-vdc-18-vdc-20-vdc-24-vdc-2000-ma-48-w-513004.html

Schaltplan: http://prntscr.com/dh7jxz

Programm: Angehängt

Wetterstation.ino (34.3 KB)

Was ist "verlaufen", "Verläuft"?

Ein Foto des Displays mit dem beschriebenen Fehler wäre hier hilfreich.

Ich vermute eine schlechte Qualität des Netzteils.
Ein Elko (1000µF) parallel zur Betriebsspannung könnte evtl. helfen.

Was ist “verlaufen”, “Verläuft”?

Ja, das Bild wird ganz Hell aber das Programm reagiert am anfang noch und lässt sich resetten. Nach ner weile wenn man das Bild nicht mehr sieht muss man denn Controller (DUE) resetten.

Bild ist angehängt

Wie machst du genau die Spannungsversorgung? Das Netzteil gibt recht hohe Spannungen aus. Überlastest du die Spannungsregler des Arduinos?

Wenn das Bild ausbleicht, dann fehlt der Takt für den Refresh, d.h. der Display Controller (oder Spannungswandler) funktioniert nicht richtig.

Oder schlechter Kontakt im Steckbrett oder anderer Verbindungen.

Allerdings ist der TO uns noch Antworten schuldig.

Wie machst du genau die Spannungsversorgung? Das Netzteil gibt recht hohe Spannungen aus. Überlastest du die Spannungsregler des Arduinos?

Wie in meiner Splan datei: Steckernetzteil auf 8V Eingestellt:47uF und 100nF Konensator mit ner Suppressordiode von 10V dnn und dann in Vin.
Der 1000uF Kondensator hat es schon ein wenig besser gemacht.

Wenn das Bild ausbleicht, dann fehlt der Takt für den Refresh, d.h. der Display Controller (oder Spannungswandler) funktioniert nicht richtig.

Also wenn ich schneller drücke dann passiert es auch schneller/häufiger wie wenn ich langsam drücke.

Also wenn ich schneller drücke dann passiert es auch schneller/häufiger wie wenn ich langsam drücke.

Echt keine Ahnung, wo du drückst…
Echt nich…

Vielleicht hast du es ja überlesen, darum nochmal, aber jetzt im Kommandoton:
Du sollst Die Spannungsversorgung messen!
Deine 8V, die 5V und auch die 3,3V!

Oder noch deutlicher:
Fehler findet man nicht durch jammern.

Im Schaltnetzteilbetieb alle auf dem jeweiligem Spannungspegel ohne Restwelligkeit.
Im USB-Betrieb sind die 5V ca 4,3V und die 3,3V va 2,8V auch ohne Restwelligkeit

Das sieht jetzt doch nach einem Spannungsproblem aus.
Irgendwo ist die Spannung zu hoch.
Poste mal die Links der verwendeten Bausteine und ein Schaltbild.

Deine Messwerte sind unglaubhaft. Entweder ist mindestens der 3,3V Regler defekt, das Meßterät oder der Meßknecht :-]

Schaltplan: http://prntscr.com/dh7jxz
Display: ITDB02-5.0 - ITEAD Wiki

Deine Messwerte sind unglaubhaft. Entweder ist mindestens der 3,3V Regler defekt, das Meßterät oder der Meßknecht :-]

Mein Oszi spinnt nur im Bereich 40kHz bis 120kHz^^

Die nidrigen Messwerte kommen ja nur im USB-bertieb vom Pc da kann der 5V regler bei Vin von 5V ja nicht ganz durchregeln. Mein anderer Due gibt mir dann Unbelasstet 4,8V und 3,2V aus

Hast Du ein USB-Scope? Dann kriegst Du im Zweifelsfall Masseschleifen, wenn Scope und Arduino über den PC zusammengeschaltet sind. Ein DVM ohne USB liefert da brauchbarere Werte.

Bei einstöpselten USB hängt kein Spannungsregler in der 5V Leitung.

Deine Spannungserzeugung ist mir schleierhaft, zu viele IC, deren Datenblätter ich mir nicht einzeln besorgen möchte. Wer ist für die Erzeugung der 3,3V Spannung zuständig, und wieviel Strom kann der liefern?

Hast Du ein USB-Scope? Dann kriegst Du im Zweifelsfall Masseschleifen, wenn Scope und Arduino über den PC zusammengeschaltet sind. Ein DVM ohne USB liefert da brauchbarere Werte.

Nein, ein normales Analog/Digitaloszi Hameg HM 507

Deine Spannungserzeugung ist mir schleierhaft, zu viele IC, deren Datenblätter ich mir nicht einzeln besorgen möchte. Wer ist für die Erzeugung der 3,3V Spannung zuständig, und wieviel Strom kann der liefern?

Grundsätzlich:
Schaltnetzteil liefert die 8V (2A max) für den Due.

Due liefert die 5V (800mA max) für das Display, Ethernetshield 2 und 3,3V (800mA max) für die Sensoren.

Das Display macht 3,3V (250mA max (Spannung) und 1,2V (250mA max) für seinen Prozessor, aus den 5V vom DUE

Am einfachsten wäre dann ein Austausch des Displays, um festzustellen, ob das defekt ist.

gamer1:
Wie in meiner Splan datei: Steckernetzteil auf 8V Eingestellt:47uF und 100nF Konensator mit ner Suppressordiode von 10V dnn und dann in Vin.

Woher kommen da 8V? Das Netzteil kann von 9 - 24V. Sicher das auf dem Stecker, der für die Wunschspannung eingesteckt ist, auch nicht durch Zufall 18V steht?

8V kann auf jeden Fall nicht sein.

Ich tippe mal auf die Steckbrücke für 18V...