DIY Arduino - Problem with uploding codes

Hello world,

I've got a problem and after reading the troubleshooting and did everything in the page on http://arduino.cc/en/Guide/Troubleshooting#toc1, I've come to a dead end.

I've wired everything using this page as reference : http://itp.nyu.edu/physcomp/Tutorials/ArduinoBreadboard and the serial from : http://sodoityourself.com/wp-content/uploads/2007/02/circuit_232.jpg

Everything was wired up correctly. Here's my basic hardware info:

-Windows XP / 7 (32-bit) -Atmega328 with 16 mhz crystal -Built with a bootloader (I did the reset test with LED on pin13) -I use USB to RS232 cable (COM4, 9600 baud) Windows recognized the hardware -Driver installed from this site( http://www.prolific.com.tw/eng/downloads.asp?id=31 ) -This problem came up ( http://s1044.photobucket.com/albums/b443/Muhammad_Syazwan/?action=view¤t=untitled.jpg )

At first I thought it was a Windows problem, so I tried on my father's XP laptop. Same result.

Now I think there is a problem with the serial cable. But the DTR works perfect (LED13 blink when I try to upload a code indicating that the DTR pin worked)(I put LED on both RX and TX pin and there is no blink, which indicates that there are no traffic going through).

Now what is the problem. I'm in a dead end !!! I want to buy an arduino but building one is 50% cheaper !!

Sorry I can't upload my board picture. FYI it is assembled on a prototype board (bread board). I planned to make my own PCB after all things worked perfectly. I hope I gave enough information for you guys to help me.

Thank you ;)

I use USB to RS232 cable

What cable? Some cables can't work at the baud rate the the boot loader switches into when downloading programs. I have a few USB / Serial adapters and cables that are good for communication but won't download code.

I dunno what cable. It's just a normal USB-Serial cable.

Would there be any difference if I buy a Serial PCI Card ?? If can I want to avoid buying a USB breakout board cause buying one would be half the price of an Arduino and full price of my BBArduino.

It is very expensive. I dunno if it is cheap to you guys but it is very expensive here in Malaysia.

And the serial from…

The nomenclature on the MAX232 is different from the typical USB-Serial modules.

Here is the way I connected a MAX232 to a homebrew Arduino:


DB9  RS232        MAX232 Pin    MAX232 Pin       Arduino 328P DIP
Pin  Name         RS232 Side    TTL Side       Pin and Signal Name
===============================================================================

2     RD    <---  14 T1OUT <--- 11 T1IN  <---  3 TXD  Arduino UART Out

3     TD    --->  13 R1IN  ---> 12 R1OUT --->  2 RXD  Arduino UART In

4     DTR   --->   8 R2IN  --->  9 R2OUT --->  Capacitor to Arduino Reset pin

5     SG    <-->  15 GND

(External Supply) 16 +5V

Is this the way you did it?

Regards,

Dave

Yes exactly. Did it work for you davekw7x ?? Well actually I wired the DTR directly to the cap and into PIN1.

Still have no luck. :-[

Well actually I wired the DTR directly to the cap and into PIN1.

Not sure what you mean but the DTR should go only to the capacitor. The other end of the capacitor should go to the reset pin which should be pulled up to +5 with a 10K resistor.

For that particular setup I am using a DB-9 serial port from the PC, not a USB-Serial converter.

All I can say is that it works for me, just as I showed.

Regards,

Dave

Well yeah...I typed it wrong :

DTR --> CAP --> PIN1

So when I tried to upload a code, the LED blinks and that I got the error.

I found this page : http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1288208997

He has almost the same problem I have. He solved it but I still can't figure out why mine won't connect. :-/

Edit: Yeah Dave, thanks for the info. Though I think I'll try to buy a serial PCI card.

So when I tried to upload a code, the LED blinks and that I got the error.

The LED blinking is the result of the last sketch being executed. The error is because the system did not get the response off your board that it was expecting, so you have many things right but something is still wrong. I am assuming you have no test equipment, that makes it trick finding out your mistake. You need to check:- 1) Is data being sent to your processor? You could attach an LED and resistor to the RX pin of the processor and see if data is being received. 2) Is data being sent back from your processor to the computer? Open up the serial monitor or other terminal device and press the reset button. Do you see something being received. You might have to change the baud rate to see something. 3) Is the auto reset happening at the right time. Again an LED and resistor (1K) should tell you if this line is changing when the upload icon is clicked.

Oh no, one problem than the other....

Now, when I press the reset button, the LED won't blink. Then, I got this error "java.lang.NoClassDefFoundError: Could not initialize class gnu.io.RXTXCommDriver thrown while loading gnu.io.RXTXCommDriver"

What the hell ?

Oh yeah , I did put a LED on the RX and it did blink, just a couple of times. It is dim.

Oh god I dunno what else to do.

Sounds like a driver error. Have you selected the right port in the menu and the right board type?

Yes. It is on COM4.
And I choosed the right board type too.
I too think it maybe the driver’s fault.

Huh… :-/

Oh no...

I downloaded the latest Arduino software but still can't upload a code. Any more suggestion ?

EDIT: I've tested the COM connection using 232Analyzer and it showed that everything works nicely.

But the signal just won't be accepted by the atmega328.

So can anyone point me to what I should do next ?? Should I buy another USB-RS232 cable or a Serial PCI card.....

Just wanted ur opinion.