Do you think my device has packed in?

Hello, I hope this category is OK as it is not really about my project.

I have been uploading code to my uno ok. Now I get error messages.

I rebooted the PC.
I have even tried using the Bare Minimum code example and get the error message included below.
Arduino sees my device as when I use a different USB port Arduino shows the new port.

Has the UNO device packed in?

Arduino: 1.8.16 (Windows 10), Board: "Arduino Uno"

Sketch uses 444 bytes (1%) of program storage space. Maximum is 32256 bytes.

Global variables use 9 bytes (0%) of dynamic memory, leaving 2039 bytes for local variables. Maximum is 2048 bytes.

avrdude: stk500_paged_load(): (a) protocol error, expect=0x14, resp=0x0c

avrdude: stk500_cmd(): programmer is out of sync

avr_read(): error reading address 0x0000

read operation not supported for memory "flash"

avrdude: failed to read all of flash memory, rc=-2

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x00

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

It appears you may have the wrong board selected. Go to tools, then Board and see if the correct board is selected. Then try loading the simple blink program. It is also possible you have a serial freeze where the arduino is constantly busy printing to the console. Launch the IDE and open the serial window and see if you are getting a lot of data and let us know.

Thanks I will try this and let you know.

Hi again gilshultz, thank you for your your suggestion. You made me look at my PC and not my device as being the issue.

I will not go into the details except to say that I spent a couple of hours on the internet following various options.

By chance on the device manager for the (com) port I selected advanced and chose an option for having issues. It appears to have fixed it. Well I've had five uploads with no issue.

Thanks John

Just an update. My above post which I thought fixed it only worked for a few goes.

I then started looking at type of programmer and board to select on the Tools menu.

I tried a few board selections but finally went back to the Arduino Uno board.

As my error messages often included the error about STK 500 I selected that programmer. This appears to work most times and even with an error message the code appears to load and operate.

The Tools > Programmer menu selection is only used when you are doing Tools > Burn Bootloader or "Upload Using Programmer". When you're doing a standard "Upload", the Tools > Programmer menu selection is completely ignored. So it makes no difference at all what you have selected from the Tools > Programmer menu.

You might see the term "programmer" mentioned in error messages from a failed upload (e.g., "programmer is not responding"), but these error messages are not referring to the same thing as the programmers listed in the Arduino IDE Tools > Programmer menu.

So any correlation between working uploads and Tools > Programmer menu are purely coincidental and will act as a "red herring" in your troubleshooting efforts.


Does the upload problem still occur after you disconnect all shields, modules, wiring, external circuitry, etc. from your Arduino board?

Hello in0.

Thanks for asking.

it does not appear to make a difference.

With or without it can fail or succeed.

I have just resigned myself to the fact that if it fails I try the upload a few more times and one of them is successful.