Does anyone know how to fix this compiling error?

I recently installed arduino on a new computer and I can’t seem to be able to compile any code. It keeps throwing this error code at me that I’ve never seen before.

Arduino: 1.6.0 (Windows 7), Board: "Arduino Uno"

/Arduino/hardware/tools/avr/avr/bin/ld.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory
collect2: error: ld returned 127 exit status
Error compiling.

I have gone through into the libraries and made sure they are in the right locations and they all are. I’m just using an example code (Servo Knob function) that I know to work on a different computer and have used many times before. I have tried other sample/example codes that I know to work and it still throws the same error code at me. The Servo example code is below for reference.

/* 
 Controlling a servo position using a potentiometer (variable resistor) 
 by Michal Rinott <http://people.interaction-ivrea.it/m.rinott> 

 modified on 8 Nov 2013
 by Scott Fitzgerald
 http://arduino.cc/en/Tutorial/Knob
*/

#include <Servo.h>

Servo myservo;  // create servo object to control a servo

int potpin = 0;  // analog pin used to connect the potentiometer
int val;    // variable to read the value from the analog pin

void setup()
{
  myservo.attach(9);  // attaches the servo on pin 9 to the servo object
}

void loop() 
{ 
  val = analogRead(potpin);            // reads the value of the potentiometer (value between 0 and 1023) 
  val = map(val, 0, 1023, 0, 180);     // scale it to use it with the servo (value between 0 and 180) 
  myservo.write(val);                  // sets the servo position according to the scaled value 
  delay(15);                           // waits for the servo to get there 
}

Has anyone encountered this error before? How does one correct it? Any help would be much appreciated. Thank you!

I have gone through into the libraries and made sure they are in the right locations and they all are.

Where exactly is the Arduino software installed and where are the libraries installed ?

Personally I would uninstall the software and install it again.

Arduino is in /program files(x86). Libraries are in /program files (X86)/arduino/libraries.
I should specify that these are the pre-installed libraries that are added at the initial arduino program software install. Unfortunately, I can't completely uninstall as this is a work computer and IT has to take care of anything like that (soooo lame) but I have gone ahead and re-installed the program again to a different location and the same error occurs... No clue what to do.