dommage electronique

Bonjour j ' utilise des cartes 8 relais chinoises avec optocoupleur , ce modele là :

apres un orage , il s ' avere que les relais ne " claquent " plus lors de la commande , qu ' est ce qui a bien pu griller , ou est ce qu on peut trouver les pieces a changer ?

est il possible d ' utiliser des contacteurs relais bien plus solides ?

Comment eviter que ce genre de probleme se reproduise ?

d ' avance merci .

A 4 euros c’est toute la barrette de 8 qu’il faut changer .. mais avez vous vérifié que l’Arduino est fonctionnel ?

Les équivalents que vous trouverez sont sans doute de la même origine...

Éventuellement regardez du côté des solid state relay ( genre ce truc là)

Vérifiez si vous avez besoin de relais NO ou NF

Bonjour,

Tu es sur que c'est bien la carte relais qui est en panne et non la commande?

Si c'est vraiment la carte qui a un problème tu peux essayer de changer les opto-coupleurs d'entrée, mais au prix de la carte je ne suis pas sur que la réparation vaille la peine.

Cela semble étonnant que les 8 relais ne fonctionnent plus.
Débrancher les liaisons avec l'ARDUINO et tester les entrées séparément avec un 5V.

Merci a vous 3 pour vos reponses .

l ' arduino avait fondu le jour de l ' orage :o , j ' en ai donc commandé un autre et installer avant de venir poster .

Sur la carte relais , la diode rouge s ' allume , lorsque je lance les commandes , donc je sais que l ' arduino est ok .

Par contre comme je le disais au depart , on entend pas le contact se faire , silence total .

je pencherais donc pour les optocoupleurs grillés , mais je ne suis pas certain .

C ' est bien eux qui permettent de faire coller le relais ?

Apres test manuel de haque contact , il s ' avere que tous ne sont pas grillés , certains collent encore .

C ' est bien eux qui permettent de faire coller le relais ?

ils transmettent le signal de votre pin mais en offrant un découplage (isolation). ce n'est pas directement la pin de l'arduino qui commande de coller le relais ou pas. Donc soit les optocoupleurs ont grillé soit c'est l'étage après l'opto-coupleur (mais moins probable car c'est une bobine qui fait élecro-aimant pour créer le contact).

iznobe:
Merci a vous 3 pour vos reponses .

l ' arduino avait fondu le jour de l ' orage :o , j ' en ai donc commandé un autre et installer avant de venir poster .

Sur la carte relais , la diode rouge s ' allume , lorsque je lance les commandes , donc je sais que l ' arduino est ok .

Par contre comme je le disais au depart , on entend pas le contact se faire , silence total .

je pencherais donc pour les optocoupleurs grillés , mais je ne suis pas certain .

C ' est bien eux qui permettent de faire coller le relais ?

bonjour
chaque voie doit etre identique au schema ci-desous
opto ou transistors HS ?
si les 8 voies sont toutes HS le choc electrique a du etre quand même "costaud" :smiling_imp:

est ce que les relais claquent en appliquant directement du 5 V sur leurs bobines (attention aux diode de roue librs pour la polarité du 5V

Si la(les) led IN1 s’allume ok , çà signifie que l'entrée opto est OK (led en serie)

Bonjour , les 8 diodes IN s ’ eclairent , et seulement 4 relais collent ( pour une carte ) .

je n’ ai pas tester les autres mais ce qui est sur c ’ est que la problematique est la meme .

il y aurait il un moyen de faire en sorte que cela ne se reproduise plus ? par exemple comme un systeme d ’ onduleur mais en 5 Volts et sans batterie peut etre

Une protection du genre de celle que donne Orange pour protéger les Boxes.

Merci henry , pour cette info , il me semble que je dois en avoir un ou 2 dans un coin .

Cependant j ’ ai realisé l ’ installation il y a bientot 2 ans et disposant d’ un onduleur , je trouvais etonnant que je n ’ avais pas relié les differentes alim a la sortie de l ’ onduleur .

j ’ ai donc pris le temps de m ’ en assurer avant , mais c ’ est bien le cas , les alims sont reliées a la sortie de l ’ onduleur :frowning: . je pense donc que la foudre n ’ est pas passé par les alimentations .

D ’ ailleurs suite a cet orage , j ’ ai du changer tout mes switchs , il faudrait donc proteger en meme temps le reseau local , faut vraiment que je mette la mains sur les protections de box du coup , si je ne m ’ abuse , elles protegent aussi le reseau , car il y a une entree et une sortie RJ 45 dessus non ?

iznobe:
Bonjour , les 8 diodes IN s ’ eclairent , et seulement 4 relais collent ( pour une carte ) .

je n’ ai pas tester les autres mais ce qui est sur c ’ est que la problematique est la meme .

il y aurait il un moyen de faire en sorte que cela ne se reproduise plus ? par exemple comme un systeme d ’ onduleur mais en 5 Volts et sans batterie peut etre

les diodes ont du “morfler” , elles sont en CC ou ouvertes ?
pour la protection un varistor sur la ligne 5V ne peut pas faire de mal

D ' ailleurs suite a cet orage , j ' ai du changer tout mes switchs , il faudrait donc proteger en meme temps le reseau local , faut vraiment que je mette la mains sur les protections de box du coup , si je ne m ' abuse , elles protegent aussi le reseau , car il y a une entree et une sortie RJ 45 dessus non ?

Non, ces boîtiers protègent le 230V et la ligne ADSL.

hbachetti:
Une protection du genre de celle que donne Orange pour protéger les Boxes.

"Donnait"......

iznobe:
Merci henry , pour cette info , il me semble que je dois en avoir un ou 2 dans un coin .

Cependant j ' ai realisé l ' installation il y a bientot 2 ans et disposant d' un onduleur , je trouvais etonnant que je n ' avais pas relié les differentes alim a la sortie de l ' onduleur .

j ' ai donc pris le temps de m ' en assurer avant , mais c ' est bien le cas , les alims sont reliées a la sortie de l ' onduleur :frowning: . je pense donc que la foudre n ' est pas passé par les alimentations .

D ' ailleurs suite a cet orage , j ' ai du changer tout mes switchs , il faudrait donc proteger en meme temps le reseau local , faut vraiment que je mette la mains sur les protections de box du coup , si je ne m ' abuse , elles protegent aussi le reseau , car il y a une entree et une sortie RJ 45 dessus non ?

Pour protéger ton installation de la foudre/surtension importantes véhiculées par le réseau Edf
tu peux installer dans ton tableau électrique un parafoudre,
voir ici un exemple d'installation
Ca ne te protégera pratiquement pas des coups de foudre directs sur ton bâtiment, ou a proximité .... mais dans ce cas, tu auras malheureusement, d'autres soucis bcp plus graves.

Tu devras aussi protéger ta ligne téléphonique avec les plugs ou des équipements spécifiques dans ta gaine électrique.
Mais pour que tout ca fonctionne correctement , il faut une tres bonne prise de terre.