Done Uploading with ZERO change

Hey guys,

So I was having trouble with a program earlier, but I fixed it. Now I'm having a very different problem. I am uploading a short program to my Arduino Esplora, and it tells me that it is done uploading, but doesn't change the program at all. Now keep in mind that the change I was trying to upload wasn't small, in fact it was a VERY separate program. I'm not sure if there is something wrong with my code, or if its something with Arduino, but I could really use a hand.

Here's my code.

#include <TFT.h>
#include <SPI.h>

#define CS   10
#define DC   9
#define RESET  8  

TFT myScreen = TFT(CS, DC, RESET);

  void loop(){
  myScreen.begin(); {
  myScreen.background(0,0,0); 
  myScreen.stroke(255,0,255);
  myScreen.text("RetroMod",0,0);
  myScreen.text("Mobile",0,30);  
  }
   }
   
   void setup(){ 
   }

Any help would be widely appreciated.

Sometimes the Arduino boards based on the 32U4 processor can say "done uploading" when they have not in fact uploaded anything.

Try pressing the reset button at the time when it starts to upload and see if that fixes it.

Tried that a few times, and nothing changed.

Try holding down reset, start the upload, and then when it says uploading release reset.