Download error when downloading Arduino SAMD Boards (32-bits ARM Cortex-M0+) -> what now?

Hi dear community,

I got my new Arduino MKR Zero and want to measure sound via Infineon's IM69D130 and store the audio data as .wav in the micro sd card.

But my problem now is that I am unable to download the "Arduino SAMD Board (32-bits ARM Cortex-M0+) in the boards manager!!
The download just stops and the board manager window cannot be closed afterwards (I have to manually close it via "task manager"). How do I proceed now? Do I have to download the github project (.zip) and insert it into a special folder? I am a beginner so very sorry if this is a easy one to answer haha

Best regards,
Johannes

Try checking the contents of the black console pane at the bottom of the Arduino IDE window when that happens. There will usually be some detailed output there when a Boards Manager operation fails. That information can provide valuable clues about the problem.
Are you able to look at the Arduino IDE window after that happens? If so, pleas

Hi in0,

usually I can't. The download stops at package 4 out of 6 and then the board manager freezes.
But I just tried it again in home office. Now this got spit out in the black console:
"
CRC stimmt nicht überein, Datei ist beschädigt. Es kann ein temporäres Problem sein, bitte versuchen Sie es später erneut.
java.lang.RuntimeException: java.lang.Exception: CRC stimmt nicht überein, Datei ist beschädigt. Es kann ein temporäres Problem sein, bitte versuchen Sie es später erneut.
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:179)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.Exception: CRC stimmt nicht überein, Datei ist beschädigt. Es kann ein temporäres Problem sein, bitte versuchen Sie es später erneut.
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:105)
at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:60)
at cc.arduino.contributions.packages.ContributionInstaller.install(ContributionInstaller.java:112)
at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onInstallPressed$2(ContributionManagerUI.java:172)
... 1 more
"

What information can I get out of this @in0 (or other friendly users)?

Best wishes,
Jojo

Hi again,

a quick note:
It worked now! After I tried it the first time (see comment above) I tried it a second time. Now it worked, but I had a pop-up window where I had to confirm my windows name and password which did not work because I had no admin right on my work laptop. Therefore I had to deny the pop-up window with "no". But the download was still successful:

Do you think that the Deny of this windows pop-up has consequences @in0 ?

Did the pop-up happen towards the end of the Arduino SAMD Boards installation process? If so that was the confirmation for installing the drivers for the SAMD boards.

If you are able to upload to your SAMD board without problems then the driver installation is not needed.

If you find that the board is not recognized then you will need to install it. You can do that manually by running the batch file named post_install.bat that is located in the Arduino SAMD Boards platform installation folder (something like C:\Users\<user name>\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.8.11\post_install.bat)

Yes it happened at the end. I now uninstalled the Arduino SAMD Boards and installed it back again with admin rights. Now that works.

I plugged my MKRZero on and tried to run the basic "blink" sketch, but while uploading the usb connection unplugs itself. Afterwards it plugs in again and no error message occurs. The sketch "is successfully uploaded" but the blink sketch did not run on the MKRZero. The console says:
"
Atmel SMART device 0x10010005 found
Device : ATSAMD21G18A
Chip ID : 10010005
Version : v2.0 [Arduino:XYZ] Dec 20 2016 15:36:46
Address : 8192
Pages : 3968
Page Size : 64 bytes
Total Size : 248KB
Planes : 1
Lock Regions : 16
Locked : none
Security : false
Boot Flash : true
BOD : true
BOR : true
Arduino : FAST_CHIP_ERASE
Arduino : FAST_MULTI_PAGE_WRITE
Arduino : CAN_CHECKSUM_MEMORY_BUFFER
Erase flash
done in 0.837 seconds

Write 10996 bytes to flash (172 pages)
[==============================] 100% (172/172 pages)
done in 0.088 seconds

Verify 10996 bytes of flash with checksum.
Verify successful
done in 0.011 seconds
CPU reset.
"

Can you help me on this one @in0 (or other users)?

Make sure you are using the version of the Blink sketch like you get from the Arduino IDE menus at File > Examples > 01.Basic > Blink. The reason I say this is because you can find some blink sketches that assume the built-in LED is on pin 13, as is the case on the classic Arduino boards. But the MKR Zero's microcontroller has enough pins to allow the LED to be put on a dedicated pin (32) so it doesn't interfere with the use of one of the normal pins. There is a macro named LED_BUILTIN that is set to the correct pin for the LED. The official Blink example uses this macro to ensure it will work on all Arduino boards no matter which pin their LED happens to be on.