download problems : Diecimila and Mega  (Newb)

I have installed Arduino IDE on Ubuntu 10.4,using both Ubuntu repository and Arduino website. . A Diecimila worked OK first day, now only produces download time-out. . The Mega has only produced download time-out. I have confirmed the serial port and board each time. The green light is always on, the yellow RX Led blinks at the start of the download, then the time-out happens. Any advice would be welcome.

Download dialog for Mega follows :

Binary sketch size: 1416 bytes (of a 126976 byte maximum) avrdude -v -v -v -v -patmega1280 -carduino -P/dev/ttyUSB0 -b57600 -D -Uflash:w:/tmp/build4811224102917183109.tmp/blinktest1.cpp.hex:i

avrdude: Version 5.10. compiled on Mar 29 2010 at 15:03:00 Copyright (c) 2000-2005 Brian Dean Copyright (c) 2007-2009 Joerg Munsch

System wide configuration file is "/etc/avrdude.conf" User configuration file is"/home/username/.avrduderc" User configuration file does not exist or is not a regular file, skipping

Using port: : /dev/ttyUSB0 Using programmer : arduino Overriding Baud Rate : 57600 avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: Send: 0 [30] [20] avrdude: ser_recv(): programmer is not responding avrdude: stk500__recv(): programmer is not responding

avrdude done. Thank you.

<>

I had screwed the Arduinos to a piece of foam-board, and some sort of capacitance effect stopped the USB ports from running correctly. Off the board they work fine. I will try again with spacers, but at least the problem is solved !! I hope that this helps other newbies.