driving 2 12v 2A DC motors with Mega

Put the meter on the X10 scale, and make sure that the meter is properly zeroed (connect the multimeter leads together).

Ohms are read right to left off the green scale.

This is what I got after touching leads and having it on X10

ac0e3576-044a-4974-badb-3af7a307b66c.jpg|900x1600

This takes me back, I haven't used an analog meter for, well, a while.

This is what I got after touching leads

To zero the meter you hold the leads together and physically adjust the meter to read 0 Ohms. Carefully adjust the screw in the yellow box till the needle lines up with 0 Ohms. Then, please post a new reading.

meter.jpg|465x327

The zero adjust screw on the front, at the base of the pointer is for zero Volts, not Ohms!

Most meters of that type also have a zero adjust thumb wheel for Ohms, as zero is the other end of the scale. You have to adjust both.

Instructions on meter reading.

Sorry, like I said it has been a (long) while since I used an analog meter and I do now remember the Ohms adjust.

meter knob.jpg|215x196

Ok so I put it on X10 and adjusted the meter. and this is the reading that I got.

cc2ec90a-f29e-42e8-9f2b-81ee1a842912.jpg|900x1600

Did you follow the instructions to zero both ends of the scale first?

What is your interpretation of the indicated value?

yes I zeroed in both ends of the scale. it seems like it is 1.8 ohms.

1.8 Ohms sounds reasonable, in which case the start/stall current, operating from a 12V supply, would be around 6.7 Amps. A 10 Amp motor driver should work.

Or, follow this tutorial for a MOSFET driver http://bildr.org/2012/03/rfp30n06le-arduino/

Contrary to the advice given in that tutorial, you should use a logic level MOSFET, like the one recommended.

jremington: 1.8 Ohms sounds reasonable, in which case the start/stall current, operating from a 12V supply, would be around 6.7 Amps. A 10 Amp motor driver should work.

Or, follow this tutorial for a MOSFET driver http://bildr.org/2012/03/rfp30n06le-arduino/

Contrary to the advice given in that tutorial, you should use a logic level MOSFET, like the one recommended.

Ok so the tutorial makes good sense and all. Now On one of the motors I need to be able to connect the Optical sensor to the Single-head pump. This is what will controll on/off. So I would need to run the sensor in-line with the mosfet between the gate and the arduino?

Optical sensor to the Single-head pump

What optical sensor? I see no optical sensor in any of the links.

Is this a sensor that counts motor rotations or something else?

There are many types of "optical sensor". We need more information about your sensor. What is the sensor sensing?

So I would need to run the sensor in-line with the mosfet between the gate and the arduino?

No, you would connect the sensor to the Arduino, read the sensor with the Arduino and control the motor based on the data from the sensor and some rule(s).

So the sensor can be found at this link. And if I understand correctly I attach that separately to the Arduino and use the Arduino to read the optical sensor and then based on the reading of the sensor the Arduino talks to the motor?

https://www.amazon.com/Optical-Infrared-Sensibility-Controller-Marinecolor/dp/B00Z9NUJWW/ref=pd_nav_hcs_rp_t_1?_encoding=UTF8&psc=1&refRID=5TAZMG4NSD6FTGK8DA06

And if I understand correctly I attach that separately to the Arduino and use the Arduino to read the optical sensor and then based on the reading of the sensor the Arduino talks to the motor?

That is right.

Have you connected the sensor and can you read it?

I really don't have any idea how to properly connect the sensor. The 4 wires are all different. This is why am looking for advice on here. I honestly know nothing about how all of this is supposed to work.

For wiring and usage instructions, consult the technical or user manual that comes with the sensor.

Part of the issue is that I have contacted the manufacturer and they haven't gotten back with the wiring diagram or anything

I buy only sensors that come with technical data and instructions.

I think that the sensor is wired like this:

Google "Optical Infrared Water Liquid Level Sensor " and this is a common 4 wire diagram.

OPTO SENSOR.jpg|460x268

TwinkleToes: yes I zeroed in both ends of the scale. it seems like it is 1.8 ohms.

It's been a very long time since I used an analog meter BUT

On the X10 range that would be 18 ohms

groundFungus: I think that the sensor is wired like this:

Google "Optical Infrared Water Liquid Level Sensor " and this is a common 4 wire diagram.

Wouldn't that mean that I would need some resistors off the yellow and red wires before going to ground? Im new to reading schematics and the like.