DS3231 module isn't seen by Arduino nano (I2C scanner finds 0 devices)

Onboard battery is alive, its voltage is about 3V3. Pull-up resistors on SDA and SCL is detected by multimeter from these pins to VCC pin (2 x 4.66 kOhm). Both Nano and RTC were Chinese modules bought at AliExpress. Nano had worked successfully in another project, but I2C bus hadn't used there. RTC is brand new, out from the antistatic bag. What should I do next in order to make it work? Should I make Nano I2C bus to detect some other device in order to locate the trouble?

My Nano’s I2C bus doesn’t see the HTU21/SHT21 module as well. I use this I2C scanner software:

// I2C Scanner
// Written by Nick Gammon
// Date: 20th April 2011

#include <Wire.h>

void setup() {
Serial.begin (115200);

// Leonardo: wait for serial port to connect
while (!Serial)
{
}

Serial.println ();
Serial.println (“I2C scanner. Scanning …”);
byte count = 0;

Wire.begin();
for (byte i = 8; i < 120; i++)
{
Wire.beginTransmission (i);
if (Wire.endTransmission () == 0)
{
Serial.print (“Found address: “);
Serial.print (i, DEC);
Serial.print (” (0x”);
Serial.print (i, HEX);
Serial.println (")");
count++;
delay (1); // maybe unneeded?
} // end of good response
} // end of for loop
Serial.println (“Done.”);
Serial.print (“Found “);
Serial.print (count, DEC);
Serial.println (” device(s).”);
} // end of setup

void loop() {}

2 x 10 kOhm pullups are detected on HTU21’s SDA and SCL pins. No devices / addresses are detected… ((
Wellll… HTU21’s sketch writes ‘HTU21 sensor isn’t present’… Wiring is definitely okay, so have I dead Nano’s I2C bus?

Solved. Faulty (cut-off) plated via is detected on Nano's "A4" pin... Fixing...

Solved. RTC is running (Adafruit RTC3231 master library). Thanks a lot to everybody! ))

a_schabanow:
Solved. RTC is running (Adafruit RTC3231 master library). Thanks a lot to everybody! ))

Your welcome :slight_smile: Even though you had requested and fixed problem without any help from people on here. :sunglasses: