DS3231 RTC error: RTC Sync FAIL

I have a DS3231 RTC module ZS-042 connected to an Arduino Uno R3.

I installed the DS3232RTC library from GitHub - JChristensen/DS3232RTC: Arduino Library for Maxim Integrated DS3232 and DS3231 Real-Time Clocks
I uploaded the SetSerial sketch and set the date and time. That went okay.

Then I removed the Arduino Uno from the laptop.

When I plugged the Arduino Uno back into the laptop and started up the Serial Monitor.
I get the error message RTC Sync FAIL!

The date and time are back to 01Jan1970 00:00:00

I am not sure what I am doing wrong.
There is a CR2032 battery.
I have cut the trace on the board per ZS-042 DS3231 RTC module - Sensors - Arduino Forum

I was expecting that the read back of the date and time would be what I had set.

check all connections.
do an address scan to verify "its alive"

I powered off my Windows 10 laptop.
Went to dinner.
After dinner I tried the setup on my Linux PC. I re-loaded the sketch, and then it worked.

I am not sure what happened.