DSO Nano v3 new purchase, issues RESOLVED by BenF f/w

Hi all. I’m working my way up towards real test equipment. My first purchase was a Gabotronics Xminilab Portable. The first one I bought (very early model) bricked itself somehow, but the 2nd one has been very reliable. I found it pretty cool in concept, but the 3 button user interface was so cumbersome (you can quickly get lost in all the submenus!) that in the end I use it only in two modes: voltage display, and logic analyzer (it has a pretty good i2c sniffer built in, and you don’t need a laptop to display data). My second purchase, very recent, was a DSO Nano v3; I guess I should have read the reviews here first, but it was cheapish and seemed simpler to operate than the Gabo device and I thought it might be my go-to miniscope.

I received it just yesterday, gave up on the official manual very quickly :slight_smile: and instead watched a couple of YT videos. Armed with that tutorial I set up a square wave (PWM output) on a duino pin and attached the scope. So far so good, I could see the square wave. But some things about it don’t seem to be as described in videos. I was wondering if someone who does use one of these gizmos regularly could tell me whether what I’m seeing is normal (i.e. the device is just like that) or whether I have a defective unit.

  1. When first connected, my square wave was scrolling and flickering as I would expect with trigger level not set. When I moved the trigger threshold (green line) downwards toward the square wave trace, the trace stabilised before the threshold ever reached it. According to tutorials, I should have had to move the thresh onto the trace (somewhere between min and max amplitude) in order to stabilise. But the trace settled down with the thresh more than 1v above max amplitude (top of square wave). And when I moved it further down, actually within the profile of the square waves, the trace destabilised again.

  2. I can display my square wave at 1v per small graticule line, so my wave form is about 5 small divisions high. But this takes up less than half the screen. I wanted to take a closer look, so I tried changing Y scale. But as soon as I went to < 1v per div, the trace leapt downward so that most of it was off the screen and only the tops of the wave forms were visible. When I tried to reposition it upwards with Y Offset, it refused to move more than a very small distance. I expected to be able to scroll it upwards to see the entire wave form at the larger scale.

  3. setting the waveform back to the largest scale the device will allow, I tried moving it up and down with Y offset. When I moved it upward, something very odd happened. After only a small amount of upward offset, the tops of the square waves disappeared and long vertical “ghost” (faint) traces appeared running off the top of the screen, as if the (only moderately noisy) signal had become insanely noisy.

All three strangenesses seem related in some way, i.e. some kind of confusion about Y axis. But is the confusion mine, or the device’s?

I did check the splash screen and my firmware version appears to be the current one, so I don’t see any point in a firmware reload. OTOH there is some talk online about an alternative open source firmware called BENF. I really don’t want to brick the device, but am wondering whether I should dare to mount it as a USB drive and try putting the BENF firmware on it.

I know what some of y’all are going to say – fgs, stop messing about with cheap toys and get a real bench scope. In fact I did give in and order my “xmas present to self” today, a Gratten 2ch digital bench scope (same model Sparkfun used to sell). It’s not a great lumbering brick like the things we used when I was young, but it has an encouraging spec and enough knobs and buttons to seem fairly serious. And I’ve actually spent as much on my mini-scope purchases as the Gratten costs, so in hindsight I should have just bought the real thing in the first place. But I really liked the idea of a “micro-scope” so to speak, something I could wear on a Velcro-equipped wrist band, something I could slip into a pocket.

Anyway, I get the impression from previous posts that some members do use the Nano v3 and find it good enough for routine debugging, so was hoping someone who knows the device well might tell me whether I got a lemon, or need different fw, or just don’t understand its limitations yet?

PS I should note that I really did try to get registered on the Seeedstudio forum to ask this Q, but have not yet managed to do so; their links seems broken, I get misdirected to product catalogue pages instead, etc. Should also note that I just tried the BenF firmware and got a white sizzling screen & no functionality, so that’s not a winner. There is a thread on the forum explaining how to upgrade to BenF, and a note saying that a patched version (BenF_3.64APP_3.53LIB_patched_v2.zip) is required for v3 Nano, which would explain why my attempt failed. But the DL link for this patched version is broken (sigh)-- their forum site returns an error “unable to deliver file”. I’ve been hunting for the same file elsewhere but so far no luck. harumph. starting to agree with those who say support for this device is pretty poor.

PPS (2nd edit) after following a lot of dead links I finally found this one:

where some kind person posted the correct BenF fw file (patched for different lcd screen) to Google Docs for posterity. Having loaded the BenF fw I find the whole device is far more functional & easier to use and definitely handier than the Gabotronics gizmo. Maybe I didn’t need to buy the Gratten after all (ouch!) … I am now able to adjust v/div, time/div, trigger thresh, and trace position on the Nano to my satisfaction! Maybe this purchase will not be regretted after all.