DSO Nano V3 - not impressed


I’ve been playing around with my new DSO Nano V3 and for the life of me cannot get the purple decaying since wave “DATA” trace to get off the screen.

I have studied the so called “manual” and tried many times to contact Seed Studio support but all that for nothing…

It’s really a shame that the device which seems to be ok in general has such a big defect and poor support.

A screenshot of the display is attached.

Anyone have a suggestion? Is there an alternative firmware perhaps? Benf does not work for V3…



Have you tried a firmware update as mentioned near the bottom of the page?


Have you tried a firmware update as mentioned near the bottom of the page?

Sadly, most or all of what is written on that page does not really apply to the Nano V3, or at least to mine. The interface is completely different and there is no card slot…

I have read elsewhere that the Benf firmware is not compatible with the V3 and thus do not want to brick my little device, which at least provides some information to me in its present state.

If the manual was at all usefull, then maybe I could get it to work better…

Anyway thanks for your help!

The first thing that went through my mind was? Is that one of the data lines? If so, what if you just connect that clip to ground. Sure, it won't remove it from the screen, but if it remains a y=0 line, then it's probably not so bad - perhaps even just 'disappear' into the axis marker.

I'm certainly not in any position to know, though my guess is that it's a bad solder join on a capacitor somewhere. It looks like a 3.2v peak, which could make sense if there was a bad path to ground. Since there's an sd card in there, at least part of the system has to be 3.3v.

So first, I'd try to ground the channel. Next I'd consider getting out the 10x (or more!) magnifier to look for bad joints.

Hi all,

I purchased a DSO nano V3.

Readed the manual, updated the firmware, and then could not acces the file menu, to save bit maps ...

Sent an e-mail to SeedStudio, two weeks ago, no answer from them.

Have installed a firmware from the seed studio, now all seems to work ok, can acces the file menu, but then my computer is not able to acces to the device. But it can acces it to update firmware.

If somebody knows how to fix this, please give some help.


I had bricked mine, but then resurrected it using the BENF firmware (attached).

I did all the upgrading from Linux, perhaps that makes a difference?

Please do not assume any guaranty that the attached firmware will fix yours. It may destroy it for all I know.

I wish I had never purchased the DSO NANO, it is really unprofessionally made junk and no support except from people like you and me…

Attached BenF firmware that worked on mine…


BenF364_LIB353.zip (49.6 KB)

Ummmm.... I was looking @the seeedstudio page for the device, $89. Had it worked correctly and been supported... But, "support" is the component that runs up the price of most merchandise.

I bet it would make a great case and display for an Arduino project :fearful:


The problem with V3 and BenF FW is, that there is no SD-Card. Please verify your Bootloader-Version and read this: http://www.seeedstudio.com/forum/viewtopic.php?f=22&t=4678&sid=4ff3b5dc41c904cb0da220b04282707c

No need for SD slot. Just use a PC and USB connection.

You did not read, what I linked?! Please read it. We are not talking about the same.

oh, you're right!

I have no solution.

I regret even more buying this stupid device....

BUT MAYBE SOMEONE FROM SeedStudio will read this and make a new firmware that actually works!!!!!

Ciao, Bob

I know this is a bit late....

The sine wave you are seeing is PURPLE, yes? Scroll down to the PURPLE menu on right side of screen. (Using up or down arrow buttons). — It's the one that says "Ex". Click "OK" button. Using the up or down arrow buttons, highlight "Ext Refn". Click the right or left arrow buttons until there is no image on the screen.

That wave is an example of a reference image. I believe you can load your own reference images in as well.



I've had my DSO Nano V3 for 24 hours now and it is working for me.

Yes, the "manual" is crap. DSO Nano users, can we write one? A wiki (a real one, not Seeed Studio's) would be a great way to collaborate on this. Some arrangement would need to be made to deal with version differences. BenF f/w needs documentation too.

The user interface is cumbersome and difficult to learn (especially in the absence of a readable manual), but I am getting the hang of it. I have to say that the digital 'scopes I used years ago were not all that easy either, and they cost more than 100 times as much.

Is it a great 'scope? No. I figured, even before I ordered it that it might be comparable to the $5 multimeter (from Harbor Freight) that I use for my Arduino projects: not accurate, not flexible, but mostly adequate. It IS gonna let me do some things with sketches involving dynamic signals that I sure couldn't do with a meter, or even Mr. Gammon's fabulous Frequency Counter Sketch.

And the hardware and software are both open source, so I expect improvements, which I might even contribute to (If I can figure out how to cross compile for ARM).

I'm working on a (almost) sine-wave DC-AC inverter that's basically working, but I can't look at the output waveform without a scope.

I also had a look at the voltage across the LED in a Joule Thief (google it!) and was amazed!

And I'm really grateful to learn how to get that damned "Reference Wave" off the display, Thanks!

In a further development, I added a 3.5 mm phone jack to my cheap meter to allow me to use the Nano’s probes!