Dubbio sulla tension

Ciao a tutti, a causa di un deprecabile errore (!) mi ritrovo con un porta batterie che contiene 3 stilo da 1.5V invece che 4. Il voltaggio in uscita quindi è di 3*1.5V =>4.5V.

Ho letto che arduino sarebbe meglio alimentarlo con un minimo di 5V... per cui se uso questa tensione rischio qualche instabilità? Ho provato e funziona, e la mia intenzione sarebbe di usare questo pacco batteria solo per pilotare arduino, mentre altri elementi (2 servo e un sensore Ping) saranno alimentati da un pacco batterie separato.

Lo chiedo anche perché la pila che risparmio la potrei usare per il pacco batterie separato :)

Personalmemte non ho mai usato arduino con batterie quindi non ho esperienza in merito, però ragionandoci semplicemente credo che se arduino funziona bene con un'alimentazione da 5v, anche se ho letto sulle specifiche che l'alimentazione raccomandata è di 7-12V, avrai problemi a farlo funzionare a lungo con soli 4,5v, questo perchè la tensione fornita dalle batterie non è costante come un alimentatore di rete, la tensione ai capi del pacco batterie tende a diminuire con l'uso, quindi con un pacco da 3 batterie da 1,5 volt avrai sicuramente un autonomia inferiore rispetto ad un pacco da 4 batterie. Resta da vedere quanto sia inferiore l'autonomia e se per te ve bene per l'uso che ne devi fare, ma se per te non è un vincolo personalmente userei 4 batterie.

Questo è il mio parere, ripeto che non ho mai usato arduino con le batterie quindi magari potresti attendere il consiglio di qualche utente più esperto o fare semplicemente delle prove.

Se il pacco batterie da 4,5V lo hai collegato alla presa jack japan di Arduino non va bene, considerando il drop-out del regolatore interno e la caduta del diodo di protezione lo stai facendo lavorare a meno di 4V, questo fa sballare anche i riferimenti logici, quindi devi fare in modo da usare ALMENO 6V.

I 4,5V devi mettere sui pin GND e 5V (non invertire la polaritá!!). Arduino da solo funziona a 4,5V. non so se l'elettronica agiunta funziona a 4,5V o meno quando sono parzialmente scariche. Devi controllare quello. Se abbassi a tensioni inferiori (3,3V) devi abassare anche il clock (sostituire il quarzo/risonatre). Siccuramente 6V sulla presa di alimentazione non funzionano affidabilmente perché non saranno 5V. Ciao Uwe

uwefed: I 4,5V devi mettere sui pin GND e 5V (non invertire la polaritá!!). Arduino da solo funziona a 4,5V. non so se l'elettronica agiunta funziona a 4,5V o meno quando sono parzialmente scariche. Devi controllare quello.

Cioè dici di applicare i 4,5V sull'header della sezione power? Ma il regolatore ed il resto della componentistica desiderata sono protetti contro le tensioni inverse? Io sapevo che si può usare il Vin ma "salterebbe" solo il diodo, dovendo comuqnue passare nel regolatore.

Siccuramente 6V sulla presa di alimentazione non funzionano affidabilmente perché non saranno 5V. Ciao Uwe

Io ho conteggiato -0,7V di caduta sul diodo e -0,2V di drop-out del regolatore, sarebbero 5,1V residui, ti risulta maggiore il drop-out?

Il regolatore è un 1117ST50T3G, datasheet: http://www.onsemi.com/pub/Collateral/NCP1117-D.PDF dropout di 1V ca. a 5V.

Confermo che da Vin si salta il diodo (quindi niente prot. in caso di inversione) ma non il regolatore.

Se "infili" la tensione nel pin 5V, invece, come ha detto Uwe, alimenti direttamente l'Arduino SENZA passare per il circuito di alimentazione (basta fare un paio di ponticelli su GND e 5V da un'altra fonte e vedere magicamente accendersi il led verde di ON).

0,2V sullo stabilizzatore sono troppo pochi. Lo stabilizzatore secondo lo schema della Arduino UNO R3 http://arduino.cc/en/uploads/Main/Arduino_Uno_Rev3-schematic.pdf é un NCP1117ST50T3G http://www.onsemi.com/pub_link/Collateral/NCP1117-D.PDF e ha un dropout massimo di 1,10V a 100mA, 1,15V a 500mA e 1,20V a 800mA.

Guardando lo schema sovracitato del arduino UNO R3 si vede che la tensione che arriva da USB tramite T1 é aplicata direttamente sul uscita dello stabilizzatore U1. Per questo una tensione di 4,5V applicata sui Pin +5V del header Power non dovrebbe dare problemi allo stabilizzatore.

Ciao Uwe

EDIT: Leo, é tempo di andare a nanna, cosí posso scrivere da solo senza il rischio che mi precedi un miunto mezzo. ;) ;)

@Uwe: e tu che ci facevi alzato? ;)

Rispondevo alla domanda due minuti dopo di Te. ;) ;)

Ah, ok, non immaginavo che il drop-out fosse così alto, sulla tensione inversa la cosa che riporti sulla versione R3 è certamente prova che non ci sono problemi. Mi arrendo su tutta la linea. :)