Due appears as COM6 port but gives error "No device found on COM6" on upload

Is there another way to give you the serial number? My wife threw away the box and any associated stickers.

Cheers,
Mike

Unfortunately there isn't another way to go back to the serial number. Can you send me a picture and possibly the invoice of the distributor where you purchased the board?

cheers Federico

It makes zero sense to put the serial number on the box but not the board. Exactly for this reason.

Greg

Federico,

This is a bit silly to have to post this, but here we go (see attached).

Cheers,
Mike

Thank you Mike, I meant to sent me the things I requested via email to the email I provided in the message above. I'm sorry for not having specified again I removed the invoice attachment contained in your reply.

We are checking the last batch of Due produced. I'll be able to answer in the coming days

Thanks Federico, Mike

Hi Frederico,

I assume that you know that the Due schematic on http://arduino.cc/en/Main/ArduinoBoardDue has R23 shown as 10K ?
It may be a documentation mistake and not a manufacturing mistake.

How can we get the documentation fixed?


Andrew

@emech: yes it is a documentation mistake that we can easily fix.

@dezguy: can you please measure the values of these resistors: R3,R14,R15,R21,R23?
See the image in the attachment for the reference.

If it's a documentation mistake that can easily be fixed, why hasn't it been fixed? It's two weeks since you acknowledged the error but still no change to the documentation. Are you trying to ensure that all the Chinese boards don't work properly? If you are then please think about the many users around the world that buy these boards, myself included.

Aren't the input capacitors on the original Italian Arduino Due rated for 16V? Then why 25V? Is Arduino producing boards with 25v? My Due board (D00000721) has only the 16V ones. Regards!

Federico asked "can you please measure the values of these resistors: R3,R14,R15,R21,R23? "

Here are the resistances from my Due board : R14 1003 ohms R15 998 R21 1000 R23 995 R3 985 Ohms

@AmbiLobe:
is your board affected by the uploading problem?
Because I see that the R23 is 1Kohm that is correct.

"is your board affected by the uploading problem?"

Summary Yes. Sometimes the upload serial upload fails and usually it works correctly.

Details My Due works correctly in many sessions. I bought it at Newark in USA. When I start working on a Sketch the Due works perfectly. I edit then Sketch, plug in the serial cable, upload the instructions to Due, and it is good. I use the Due to test performance. I disconnect the serial cable. I run the Due successfully. I power down the Due. I plug in the serial cable and use the Serial Monitor to receive messages from Due. The messages are shown on my PC video screen as good text messages from Due. I power down. I need to disconnect my custom electronics from the Due using a DB25 connector to enable any uploads. If I keep the DB25 connected to Due from my experimental board, it never uploads, so I disconnect the DB25. I write a new sketch, I plug in the USB cable for upload. Failure ! "No device found on COM7"

I exit the IDE 1.52. I start IDE again. Failure. I disconnect the USB cable and start over to try to upload again. Failure. I power down my PC and boot up everything. It works now. Upload successful.

Sometimes Serial Monitor fails also. Then it works after re-booting computer. It seems intermittent. Re-booting is not alays needed, sometimes, just closing IDE and starting IDE makes serial monitor work.

Bump. Did this ever get resolved?

Cheers, Mike

I had been running my programs fine all day until I finally encountered this problem. This thread seemed to be the most helpful, but it seems like this has been going on for a while. Since I'm relatively new to arduino, would it be better/easier if I seek a refund on my board?

OnionKnight: I had been running my programs fine all day until I finally encountered this problem. This thread seemed to be the most helpful, but it seems like this has been going on for a while. Since I'm relatively new to arduino, would it be better/easier if I seek a refund on my board?

If you have a clone board, it is situation normal, if you have a 'genuine' arduino board, I think you should try to PM Federico with date of purchase, serial number, and supplier you got your board from.

Graham

SOLVED

You need to do three very simple things after connecting the Programming port with the computer/laptop : 1. Press the erase button for about 3 seconds. 2.Press the reset button. 3. Upload the code.

[u]You need to do this every time you want to upload a sketch.[/u] Everything else will hopefully work fine after that.

P.s : I think the problem is the board is not erasing the data pre-written or something. And it is all done. Tried , tested , worked. Cheers ! --Rishi

I won't say this issue is solved. IT IS NOT SOLVED! Using the Erase Button works but is not the solution to the originating problem. Especially when debugging or trying things out it's annoying always to access the board itself.

I installed ATMel Studio with Arduino plugin - and from there it works without pressing the "Erase" Button on the Due Board and Resetting. Which is strange cause the Arduino plugin needs the location of the genuine Arduino IDE installation (in my case the latest Beta 1.5.6r2). When calling bossac from the command line it also DOESN'T detect the arduino port. The Arduino Plugin seems to do something different. Although i would suggest that the problem lies somewhere in bossac.

The DUE support doesn't seem to be very mature. And it's a strange version of bossac - which itself (the genuine one) has not been updated since a while, so it's a modificated version by the arduino team. I got none of them (neither the "genuine" nor the arduino one) to work.

I think the Arduino IDE with DUE support is called BETA for a reason. Before r2 I had massively problems with the serial console - in contrast when using other terminal programs - which worked like a charm. At least that seems to be fixed now.

Thought the power on reset might be fixed with a patch to the 16U2 (first thing that crossed my mind). Thanks. Would be nice if we could figure out why it is not working as it should without the patch, but at least we have a work around.

Hello,

Same issue here. The board worked fine for several months but now it's completely unusable. I've tried the different techniques mentionned in this topic with no success. Resistors are 1K as expected. Serial number is D00036196.

Is there something else I can do ?