Duemilanova upload problem from command line only

Environment:
Ubuntu 8.10 Linux 32-bit machine
Duemilanova board; USB cable

Compiles and uploads successfully using IDE.

I want to be able to compile and upload from the command line. After slightly modifying the sample makefiles to fix PORT and paths, I am now building successfully to a hex file, but uploading fails consistently.

$ /home/peo/Desktop/arduino-0012/hardware/tools/avrdude -V -F -C /home/peo/Desktop/arduino-0012/hardware/tools/avrdude.conf -p atmega168 -P /dev/ttyUSB0 -c stk500v1 -b 19200 -U flash:w:applet/blink.hex -vvvv

avrdude: Version 5.4-arduino, compiled on Oct 22 2007 at 13:15:12

System wide configuration file is “/home/peo/Desktop/arduino-0012/hardware/tools/avrdude.conf”
User configuration file is “/home/peo/.avrduderc”
User configuration file does not exist or is not a regular file, skipping

Using Port : /dev/ttyUSB0
Using Programmer : stk500v1
Overriding Baud Rate : 19200
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: Send: 0 [30] [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
avrdude: Send: Q [51] [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

Any ideas? Is there any way I can get diagnostic output from the IDE (since it works perfectly from there) so that I compare with what I’m trying to do directly from the shell?

I'm having exactly the same problem.

There are two lines in the preferences.txt (~/.arduino/preferences.txt), build.verbose=false and upload.verbose=false -- change them to =true to get all the output in the GUI.

I did that, and tried running exactly the same commands as the GUI, to no avail. What's the GUI doing that the command line isn't? I can't figure it out.

Mine works from the command-line once when i plug the USB cable in, but never again afterward. I've tried this on two Duemilanova boards, exact same situation.

:o

aha. see http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1201441300

Thanks for the pointer, Matt. That solved my problem too.

I've the same problem too