Duemilanove gone insane?

I have a Duemilanove (ATmega328) which I am using in a project to create an LED-lamp controller. I was testing some different ways of fading through different colors (RGB-LEDs), for which I am using a giant array of color values, but it was not working as I wanted. All of a sudden after uploading a new version the pin 13 LED started blinking like mad and after that I can’t upload new sketches anymore. It gives me this error: “avrdude: stk500_recv(): programmer is not responding”. I have tried the reset button and uploading from different computers, but the result is the same. I have double checked that the correct board and serial port is chosen in the IDE.
Could I accidentally have overwritten the bootloader with the large array I am using or what could be the problem here? How can I get my board back to working order?

When you compile the sketch, how many bytes does the IDE report?

When I try to upload the Blink example sketch it reports:

Binary sketch size: 896 bytes (of a 30720 byte maximum)

avrdude: stk500_recv(): programmer not responding
avrdude: stk500_recv(): programmer not responding

No, how big is the sketch with the "giant array"?

Binary sketch size: 1120 bytes (of a 30720 byte maximum)

The .pde file is 49K.

Any hints on getting the board to live again?

this is interesting, 3 people (so far ive counted) have reported this
avrdude: stk500_recv(): programmer not responding error... perhaps its a glitch with the new IDE?

Have you definitely got the correct Arduino Board selected in the IDE ?

Yes, I am 100% certain that the correct board is selected. It is the Duemilanove with ATmega328. Also, it happened as I was developing for it - I uploaded the program, changed a little code, re-uploaded and so on. And then all of a sudden upon an upload it went nuts. So I know that the IDE was set correctly (and I double checked after it stopped working) and the board was working fine. The board was not faulty upon delivery, nor do I think the hardware is damaged.

I can only suggest trying it on another PC or do a reinstall of the software and drivers.

If that doesn't work then maybe your chip is faulty and you may need a replacement.

Well if you have the means to reburn the bootloader that might solve the problem. If you don’t, there are several vendors that will sell you the AVR chip with the bootloader already installed for around $7 + shipping.

Lefty

I'm having the exact same problem. I don't really understand much of this, but the flashing pin 13 light doesn't start blinking until after a couple of seconds, which means that the bootloader's still there, right? I also notice that when I try to upload a program, the RX light blinks occasionally, but not the TX one. And still, every once in a while, when it's timed-out on trying to upload anything, the LED stops blinking until I try to upload something again.

Hey guys,
so yeah, same problem here with small differences. I have the Arduino Pro Mini 328 - 5V/16MHz and programming it on an Intel Macbook with OS 10.5. I do have the latest FTDI drivers as well have selected the board as it says on sparkfun - Arduino Duemilanove w/ 328
I'm also using the FTDI Basic Breakout - 5V from sparkfun

Initially i couldn't upload any sketch as the red TX light would blink a couple of times (3-4) and then go off with nothing happening and an error:
avrdude: stk500_recv(): programmer not responding
avrdude: stk500_recv(): programmer not responding

After reading the troubleshooting page I started to juggle with uploading a sketch and pressing the reset button on the board to get the right timing for the boot loader to respond.
I finally started getting it and sketches started uploading... a little shady, but uploading

After a few tests and tweaks (had probably about 8 successful uploads), I added as drzero says some arrays, which uploaded successfully for the last time and now whenever the Arduino is powered, LED 13 is blinking rapidly with no luck of uploading any new sketches. :cry:
red light blinks 4 times, no response and the following error
avrdude: stk500_recv(): programmer not responding
avrdude: stk500_recv(): programmer not responding

I was trying to upload a sketch for about 2 hours yesterday

Please advice what would the problem be. I'm going to take some suggestions here and try it on a PC to see if this is gonna do any good. I'll post if I find a successful solution to the problem! I know it is not burned, as I haven't touched the solder and haven't done anything different other then a regular upload of a sketch.

P.S. What are the steps to burn the boot loader again. is that going to help and what boot loader should I burn? I'm willing to try anything to get my Arduino to work at this point :-/

Good news! :smiley:

I decided to give it one last shot before trying it with a new computer and it worked! LED 13 doesn't flash anymore. Here is what I did:

Unplug the USB and as soon as you plug it in, right after the device powers up and right before the LED starts blinking rapidly, press the upload button. I think the timing is critical here, so you might not get it from the first time. After that you should be all set, and it should be back to normal :sunglasses: Just make sure that the sketch you're trying to upload is a known working sketch (without the crazy arrays).

Also I did add all my arrays after all which caused the thing to go nuts and what I'd suggest is declare all arrays at the beginning, where you declare your pins, because if you do it later on it my overwrite instructions or other registers, which is I guess what happened. Declaring all arrays on top though worked for me :wink:

I still have to juggle with the reset button though when I upload new sketches... any suggestions on that, is it maybe the auto-reset? :-?

Have you checked the auto-reset solder jumper to make sure that it is not that which is causing the problem... From what people are saying about having to reset it seems that it may be iffy... Try disconnecting the auto-reset jumper and see what difference it makes (if any).

Mowcius

actually I don't think i ever had a auto-reset jumper connected, so both of my RST pins on the pro mini are floating open?

Should I short one of them to something, or was it with a capacitor (i think i read that somewhere, but not sure)?

Unless yours has gone funny then it should already be enabled, that comment was more for the people with other boards

Rather then requiring a physical press of the reset button before an upload, the Arduino Pro Mini is designed in a way that allows it to be reset by software running on a connected computer. One of the pins on the six-pin header is connected to the reset line of the ATmega168 via a 100 nanofarad capacitor. This pin connects to one of the hardware flow control lines of the USB-to-serial convertor connected to the header: RTS when using an FTDI cable, DTR when using the Sparkfun breakout board. When this line is asserted (taken low), the reset line drops long enough to reset the chip. The Arduino software uses this capability to allow you to upload code by simply pressing the upload button in the Arduino environment. This means that the bootloader can have a shorter timeout, as the lowering of the reset line can be well-coordinated with the start of the upload.

This may have gone wrong, I do not have any experience with the pro mini myself so I cannot help much more,

Mowcius

Hey mowcius, thanks for the info. I did a little more testing on my side and it ended up being a problem on my end. Apparently I hadn't soldered well the male headers to the Arduino Pro Mini to plug into the Sparkfun breakout board, so I guess the reset pin was disconnected the entire time.

Re-soldering it did the job and it's all working well now :smiley:

cheers :wink:

Glad I could help :slight_smile: :wink: :smiley: ;D

Mowcius