Duemilanove not connecting

Greetings,

I’ve worked with an Arduino before with no issues, but I just got a Duemilanove and can not get it to work.

I’m on OSX, and I installed Arduino.app and FTDIUSBSerialDriver_10_4_10_5_10_6.mpkg

When I connect the Duemilanove the PWR light is solid. One thing that seems alarming is the “L” light blinks 4 times then repeats. I’ve looked for info on this pattern, but have found nothing.

When I attempt to run Arduino.app nothing happens. It appears to load (the icon reacts to my double click) but nothing launches or shows up in the activity monitor.

Any help would be greatly appreciated.

/Chris

I've downloaded and installed Arduino.app multiple times, but every time I run it, nothing happens. No alerts, no error messages, no active process in activity monitor...

I'm down to the wire on my project, and can't even start coding until I can get this app running. Really starting to get frustrated. I've run the application on multiple windows systems in the past with no issue.

/Chris

Hmm...try running it from the Terminal command line and see if it prints any error messages:

/Applications/Arduino.app/Contents/MacOS/JavaApplicationStub

http://www.ruggedcircuits.com

Thanks for the help.

When I do that, I am met with an error:

JavaVM: Failed to load JVM: /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bundle/Libraries/libjvm.dylib

Strange

/Chris

Sounds like your Java installation may be damaged. Try:

ls -al /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bundle/Libraries/libclient.dylib

http://www.ruggedcircuits.com

I get:

-rwxr-xr-x 1 root wheel 6748400 May 4 21:13 /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bundle/Libraries/libclient.dylib

That sounds a bit small in size (I expected >10Mb). It could be the file is corrupted?

I would look into repairing or downloading a new Java VM. Also try the regular Mac OS software upgrades if you've been neglecting those.

http://www.ruggedcircuits.com

I have the software update run weekly, and right now it just shows one update to Safari.

Java.com does not list a downloadable version for OSX, as they claim apple handles that via the software update tool. So I don’t see a way to manually update the JVM.

Is this OS version 10.6.4?

Try doing a checksum on all the files:

find /System/Library/Frameworks/JavaVM.framework -type f -exec cksum {} \;

Post that somewhere (pastebin?) and I'll try to compare the checksums against my system. If it's only that 1 file that's corrupt I can just send you my copy.

http://www.ruggedcircuits.com

Here ya go: http://pastebin.com/09YiE0nN

On a side not, just I deleted JavaVM.framework, which forced Software Update to reinstall everything. After the required reboot, nothing has changed. This is proving rather frustrating.

Thank you so much for your help on this, it is greatly appreciated!

/Chris

Sorry but I don't think I can help much. There are a LOT of differences in file sizes, yet some files are exactly the same size. This is all for version 1.6.0. Makes no sense to me.

????????

http://www.ruggedcircuits.com

No worries, your efforts are still appreciated.

I've really hit a wall with this one... I've done just about everything I can think to do (aside from give up)

Bit more info about my macbook: 2.4 GHz Intel Core 2 Dueo, running OS X v10.5.8

I've uninstalled and reinstalled everything multiple times, and yet the application still refuses to launch.

Go figure this happens right before the one weekend I had blocked out to work on this project. If I can't get this working tonight it looks like I'll miss the deadline and be out a few hundred bucks. I really did not expect just getting the application to launch would be the difficult part of this project, especially since I've worked with multiple Arduinos in the past with no issue. :(

/Chris

it more info about my macbook: 2.4 GHz Intel Core 2 Dueo, running OS X v10.5.8

Oh! I have 10.6.4. That's probably why there is a difference in the JVM.

You could try: a) upgrading to 10.6.4, or b) compiling the Arduino program from source checked out from Google Code. It really isn't too bad.

http://www.ruggedcircuits.com

Sadly, after all the money I dropped on this project I need to cut back on spending for a bit. (so no OSX upgrade in my near future)

And I’m not setup to compile anything.

I just don’t get what the actual problem is… I’m running what is apparently the proper (according to Apple) version of JVM, and I’m downloading the Arduino APP from the official arduino.cc site… I don’t have an exotic setup, just a MacBook Pro with up-to-date software. So things should be working.

This is all time that I need to be spending making progress on my project, but all I’ve managed to achieve is raised blood pressure and lowered faith in two products I previously loved.

I've spent many, many more hours on this (much of Friday and Saturday), and still can not get the application to load. At this point, I am furious. (Nearly 2am and I can't even sleep I'm so angry/worried for my project)

I've scoured the depths of google, but can't find anyone with the exact issue I'm running into, and I've exhausted all other available options. This forum is my last hope. (even though it may be too late to finish my project now, as I was supposed to spend all weekend on it)

I love the Arduino, but if I can't get the software to even launch, its power as a creative tool is lost. I've spent more time just trying to get the application to launch than I planned on spending writing my program.

try to connect it to Windows XP at first, to check if it has hardware problems. If it works, then start messing with other OP systems. ;) Im using Ubuntu Linux with Virtual Box (Win XP). I haven't got it work under Linux, .. Win XP works flawlessly.. Maybe you can also use Virtual Box or similar program..

Maybe you can forget "the application" for now and just compile your code using AVR-GCC and upload using AVRDUDE. That's really what the application is doing anyways. I'm sure there must be a tutorial somewhere that shows how to build an Arduino app without the GUI.

http://www.ruggedcircuits.com

Hi,

Thank god I read your problem before I cried. I have just bought my first Arduino Duemilanove and am running osx 10.4.11 and nothing....... I have the green light and the yellow is flash for 4 then short pause flash for 4.

When I build the blink trial the led does the same. I have followed all the rules and am not happy.

Hope you can solve the problem

Philip

Got it working. I ended up opening the driver with control clicking on the driver, show contents and double clicking and installing each part of the driver one by one, selected the right serial port and she runs like a dream. I expect I was just stuffing it up but it would be nice to think this might work for you

Philip

You are not alone see my post in this Forum J.Knott.