durch automasse sind leider alle lötaugen verbunden. normal?

hi,

ich habe mir platinen fertigen lassen, bei denen auf der oberen seite automasse (=copperfill) aktiviert ist. dort sind alle GNDs verbunden. die lötaugen auf der unterseite (sofern es keine vias sind) sollten nicht mit der oberen automasse verbunden sein (klar).

leider ist bei allen bohrungen innen eine leitende schicht aufgebracht, wodurch jetzt alle lötaugen unten durch diese bohrungen mit der oberen automasse verbunden sind.
werden bei der herstellung immer alle bohrungen innen beschichtet und ich muß mich selbst um die trennung kümmern (zb. indem ich ALLE lötaugen als vias anlege, oder oben "kleine" lötaugen um alle bohrungen lege), oder war das ein fehler des platinenherstellers?

ich werde jetzt die bohrungen von oben anfasen, das löst das problem (600 bohrungen pro platine, auch unlustig), würde aber gerne wissen, ob das normal ist.

liebe grüße,
stefan

PS.: was der 100% e-test von itead dann macht, frag ich mich schon...

Stefan, kannst du mal Bilder posten. Das die Bohrungen von innen beschichtet werden, ist soweit korrekt und ist bei mir immer der Fall, wobei auch gewollt.

Das Problem wird SprintLayout sein. Du hast vermutlich 1 seitige Lötaugen gesetzt. Somit besteht auf der Rückseite auch keine Rand zur Massefläche. Eagle verbessert sowas automatisch.

Die einfachste Möglichkeit wäre es, sich mal deine Gerber Files anzuschauen.

hi,

Du hast vermutlich 1 seitige Lötaugen gesetzt. Somit besteht auf der Rückseite auch keine Rand zur Massefläche. Eagle verbessert sowas automatisch.

stimmt genau, habe ich nicht. ich wußte einfach nicht um die notwendigkeit. ob es von sPrint Layout automatisch gemacht werden kann, weiß ich nicht, kann ich mir aber kaum vorstellen, hab' da noch nie was zum einstellen gesehen. das letzte layout für die tropfenfotographie hatte keine automasse.

ich hab' auf jeden fall im forum von sPrint gepostet. schau'n wer mal...

würde ja einfach neue platinen bestellen, wenn ich dann nicht wieder 8 wochen warten müßte. also 4 x 600 bohrungen anfasen. :roll_eyes:

gruß stefan

Wollst dir nicht eventuel doch mal Eagle anschauen? Oder sind deine Platinen in der Regel größer als 10x8cm?

hi,

stefan, lieber nicht. eagle ist mir unsymphatisch, allein von der optik der platinendarstellung her. die bedienung nicht intuitiv, aber der wichtigste grund ist, daß eagle dafür gemacht ist, von einem schaltplan auszugehen, das tue ich nicht.

ich muß also meinen "schaltplan" beim layouten entwerfen, und dafür ist die optik von sPrint für mich viel übersichtlicher.

jedes programm hat stärken und schwächen, daß sPrint vielleicht nicht automatisch bei den bohrungen korrigiert, damit kann ich leben.

gruß stefan

EDIT: die platine mit dem fehler ist 10x10.

Bedienung ist noch nicht ganz so ausgereift wie man es sich erhofft hat bei den letzten Versionssprüngen. Das Bedienkonzept mit der Maus ist manchmal etwas mühsam. Unteranderem da die Tastenkürzel nicht dem Standard-Tastenkürzeln entsprechen (c&p ...)

Einen Schaltplan brauchst du nicht zwingend. Wobei ich den empfehle. Wenn du ein neues Projekt auf machst, darfst du halt nur nicht ein neunen Schaltplan sondern nur Board anlegen.

Wobei dein Projekt wäre so nicht für lau realisierbar mit Eagle. Leiterplatten größe ist in der freien Version auf 10x8cm (halbe Eurokarte) begrenzt. Eine Hobbyversion kann bereits Eurokarten. Kostet aber mal eben 140Teuros netto.

Für mich spielt das keine Rolle, da meine Layout immer wenn möglich <= 5x5cm betragen.

Wobei dein Projekt wäre so nicht für lau realisierbar mit Eagle.

Torrent Seiten machens Möglich :smiley:

:grin: Sowas brauch ich dann nicht.Alles > 5cm wird auch wieder teurer

Was mich noch bei kostenloser Eagle Version ankotzt, man darf die Bauteile nicht ausserhalb der Platine ablegen.
Aber im groß und ganzem bin ich zufrieden damit.
Was den Schaltplan angeht, den kann man immer gebrauchen. Nachträglich für jemanden zu erstellen wird noch schwieriger. Und wenn die Platine fertig ist, kann man besser auf dem Schaltplan die einzelnen Pins ablesen um im Code zu benutzen.

Was nun deine Platine angeht... ist doch alles richtig?

skorpi08:
Was mich noch bei kostenloser Eagle Version ankotzt, man darf die Bauteile nicht ausserhalb der Platine ablegen.

Hätte ja gereicht, dass man dann keinen CAM ausführen kann. Aber immer dieses meckern :angry:

skorpi08:
Was nun deine Platine angeht... ist doch alles richtig?

??????????

hi,

Was nun deine Platine angeht... ist doch alles richtig?

falls Du meine meinst: eben nicht. alle pins sind miteinander verbunden. ich werde alle bohrungen oben anfasen, dadurch sollte das problem gelöst sein. dann seh ich erst, ob ich richtig geroutet hab...
die eine angefangene löt ich vorher zur übung noch mit den 15 IC-sockeln voll.

gruß stefan

In dem TuT sagt der Typ, alles was GND heißt, wird mit GND verbunden! Und warum sollte GND nicht mit GND verbunden werden? ist doch eigentlich der Sinn der Sache?!

hi,

Du hast das falsch verstanden. es sind nicht nur (so wie es sein sollte) die GNDs miteinander verbunden, sondern absolut alle lötaugen.

ich fase gerade alle nicht-vias oben ab, geht mit einem 4,5mm-bohrer (nur mit den fingern, ohne maschine) einwandfrei und schnell. damit kann ich leben...

gruß stefan

Na, das Problem ist hier nur, das Splan nich beide Seite berücksictigt. Soll heißen, wenn auf Seite A ein Via gesetzt wird, ist dieses auff Seite B noch nicht da.

hi,

um das nochmal aufzuwärmen:

Das Problem wird SprintLayout sein. Du hast vermutlich 1 seitige Lötaugen gesetzt. Somit besteht auf der Rückseite auch keine Rand zur Massefläche. Eagle verbessert sowas automatisch.

das heißt also, bei automasse MUSS man durchkontaktierungen setzen?
klar kann ich das mit sPrint auch, aber dann muß man halt noch einiges nacharbeiten, weil ich auf der oberseite etliche male mit leiterbahnen zwischen zwei lötaugen durchgehe. ich habe jetzt einfach bei allen einseitigen lötaugen ein "kleines" lötauge auf die obeseite dazugesetzt.

zwei dinge sind dabei ärgerlich:

  1. daß man bei vias nicht getrennte lötaugengrößen für oben und unten angeben kann (schon beim erstellen).
  2. daß sprintlayout beim test diese ungewollten durchkontaktierungen nicht berücksichtigt.

bestelle mir jetzt noch mal 10 stück, habe ohnehin noch einiges geändert. und so teuer ist das zeug nicht.

gruß stefan