EAGLE ground plane

In EAGLE, I always find the ground plane that I had is not displaying after I close a design and reopen it. I had to push ratsnest to see the ground plane. If I export gerber file right after opening a design, while the ground plane is not displayed, I do get the right results. I wonder if there is a way to display the ground plane without pressing the ratsnest button. Thanks.

Eagle as a user-supplied init file that runs after it starts up (eagle.scr in some directory that depends on your setup.)
I put a “ratsnest” command in there for just the reasons that you mention. It only seems to end up being what I want about 75% of the time…

Thanks westfw. I got an email from DorkboxPDX, where I placed a PCB order, they don't have a good way to tackle this either. If it works on my computer, I will pass your trick on to them. I can already sleep better now that I'm sure the planes are there but just not being displayed. :sleeping:

UPDATE: just tried. Worked out beautifully. Thanks again westfw!

Cool. In the other direction - how would you tell eagle to "unpour" after pushing ratsnest without closing and reopening? Sometimes I have to reroute some traces after computing the pour. How would I get rid of the ground plane without reopening eagle? Any hints for this?


Do you mean to not display the ground planes so you can see your board better? Even the ground plane is not displaying it’s there.

how would you tell eagle to "unpour" after pushing ratsnest without closing and reopening?

"ripup" will un-pour a polygon, or to unpour ALL your polygons you can use:

ripup @;

Hi Westf,

thanks a lot for this hint. I did not find it in the manual. This will definitely help me a lot :slight_smile:


Karma for you westfw! I'll save this on my EAGLE cheat sheet!