EAGLE trouble again

I'm trying to upgrade to 5.11 but it is asking for installation code. I don't recall what I did with 5.9 but I was able to install my lite version just fine. I have the license file and my serial code and some download code. No installation code! Any hint? Thanks. Why is EAGLE not able to just upgrade itself but instead wants you to manually install the new version?

How do I transfer my libraries, with some of them already altered?!

Just copy the eagle.key file from your previous installation to the new one (it should be in the 'bin' subdirectory).

As for transferring libraries: DON'T! Don't modify Eagle's libraries directly -- create your own and copy their parts into your own for modification. If you know which ones you modified you can just copy the .LBR files from the old installation to the new one....but this is not a good long-term strategy as you will overwrite library fixes and updates in newer versions.

-- The Aussie Shield: breakout all 28 pins to quick-connect terminals


I tried to copy eagle.key from 5.9 to 5.11. When I run 5.11, it still shows for educational uses! Well, anyway, I have the lite license to cover my behind just in case some crazy lawyer wants my money:)

I've got my own library but kind of half way into modifying existing libraries. I will keep my 5.9 version until I get back from Cadsoft on install and think about what to do. I could just go with 5.11 and if I see a part that is "old" I'll fire up 5.9 and transfer the part to my library.

I got back from their rep. Turned out I didn't write down the installation code when I was downloading my license file. They removed the license file link so I couldn't get it online. They emailed me and offered some advice on how to keep my EAGLE stuff in one place. One flash drive, save the following: installation code and serial code in txt file, then the license file.