Easy Driver linear actuator not moving

Good morning guys, i sa[l]vaged a captive linear actuator, tried moving it with easy driver, but i have several problems.

The actuator is a bipolar motor with step angle of 15°, winding voltage of 5v@250mA /12v@100mA.
It should work with 2.5W

When i tried using easydriver, it makes some noise, but does not move. I tried changing all the settings, reducing and increasing the delay from one step to another, going from half step to full step, it moved only once, wobbled a bit, then moved no more.

I already switched from the arduino Voltage Output to an external 12v power supply.

There are chances that i connected the pins of the motor incorrectly, and the easystepper does get hot

EDIT/UPDATE:
I managed to move it, after moving a bit manually (it seems that sometimes it gets stuck at the end or at the start of the shaft), and by putting MS1 on HIGH and MS2 on LOW, so half step mode. I also tried all the possible combination of pins, probably i missed the only working one (don't know, guys)
I managed to make it move even with steps at 900microseconds. If i go at 800 it goes wobbly again (i know it could be faster, that's why i tried 800microseconds, so i tried)

Now i'll try to power from the arduino board.

I have to ask you a question: since i noticed some grease leaking from the shaft, could it be that it lost some lubricant, so it gets stuck?

OK, I'm starting over with this comment since I just had too many thoughts while writing it. Gonna list them now:

  • If you actually have a stepper, there should be absolutely no way to wire it incorrectly in a manner that damages a fitting driver board. Steppers run on DC/Rect, so there is no such thing as a short (the output is always kinda shorted by the coil, that's by design. The driver should be able to handle that).

  • Steppers and their drivers getting warm to the touch, tho, is normal. A stepper without a heatsink, for example, can easily reach 100°C or more (not saying thats good, just normal if used incorrectly, meaning without proper thermal management).

  • If you are sure your driver is rated for the type of stepper you are using, your problem may actually be the system inself being stuck. The driver will naturally ramp up the voltage if the step isn't complete to increase torque. This - in turn or rather by basic design - leads to a linear increase in coil current. The driver will cap out eventually and just keep feeding current, heating up the system. Modern drivers should have a thermal shutdown, tho.

  • If you are not loading the system, grease shouldn't be much of an issue. The main purpouse of thick lubricant is to help the system work under load, while thin oil is usually used if something wouldn't work without lubrication at all. Lubricant leaking, however, means two things:

  • You have a hole, so water influx is a possibility

  • Something in there is pushing out that grease, which shouldn't be the case in a linear actuator

Having said that and not knowing where you got the thing from and in what condition it is, I'd not exclude the possibility of internal mechanical damage which lead to the slide getting stuck. That's just my gut, tho.

I hope I could help or at least nudge your troubleshooting in a successful direction. Happy Making!

Daniel