EasyDriver und Nema 17 stottert

Hallo liebe Gemeinde,

ich habe mir im letzten Jahr eines dieser Komplettsets bestellt, um mit dem programmieren anzufangen, um später ein Projekt umzusetzen was ich schon länger im Kopf habe. Die Anleitungen auf Funduino.de waren für die ersten Schritte sehr hilfreich.

Doch nun zu meinem Problem:

Ich schaffe es nicht, Schrittmotoren ans laufen zu bekommen! (der kleine beiliegende ja, andere nicht)

Der nema 17 scheint zwischen zwei schritten hin und her zu springen, was je nach Frequenz einem Brummen ähnelt. nehme ich die Geschwindigkeit herunter, kann man es gut mit den Augen sehen. Von Rotation keine spur, geschweige denn Drehzahl.

Die von mir verwendeten Komponenten sind:

Arduino UNO:
https://www.funduinoshop.com/epages/78096195.sf/de_DE/?ObjectPath=/Shops/78096195/Products/02-01

EasyDriver:
https://www.funduinoshop.com/epages/78096195.sf/de_DE/?ObjectPath=/Shops/78096195/Products/03-127

AdafruitShield:
https://www.funduinoshop.com/epages/78096195.sf/de_DE/?ObjectPath=/Shops/78096195/Products/03-42

Nema17:
https://www.funduinoshop.com/epages/78096195.sf/de_DE/?ObjectPath=/Shops/78096195/Products/03-125

Als sketch habe ich folgende anleitungen aus dem Internet verwendet:

http://www.schmalzhaus.com/EasyDriver/Examples/EasyDriverExamples.html

Jedoch schon in dem ersten versuchsaufbau ist mit dem easydriver keine Drehzahl da.

Könnte mir jemand hier aus dem Forum etwas unter die Arme greifen und mir sagen wo der Fehler liegt?

P.S. Falls es hier Jäger/Sportschützen unter uns gibt, ist mein Vorhaben für euch sehr interessant. Ich habe vor eine Laufende Keiler Schießanlage zu bauen, welche mit dem Luftgewehr zu betreiben ist. Diese soll mittels Schrittmotor angetrieben werden. Die Mechanik ist zu einem großen Teil schon fertig gestellt, nur hänge ich jetzt bei den Motoren etwas fest.

Welche Versorgungsspannung für den Motor hast Du?

Der Motor Teilenummer: 42BYGHW208; Spannung: 12V; Aktuell: 0,4 A / Phase ist mit einem Stromtreiber A3967 nicht richtig ansteuerbar (auch wenn Fundino den Motor für diesen Treiber vorschlägt)
Damit ein Motor gut funktioniert muß der Treiber mit ca dem 4-fachen Spannung versorgt werden. Der Treiber kann aber nicht mit 50V versorgt werden.

Grüße Uwe

EasyDriver und AdafruitShield zusammen, wie hast Du das verkabelt?

Erstmal vielen Dank für die schnellen antworten,

  1. natürlich habe ich nur versucht einen der beiden Treiber zum laufen zu bekommen, nicht beide zeitgleich.

  2. Als versorgungsspannung habe ich ein olles 12V mini Netzteil hergenommen, das grade so rumlag. Gemessen habe ich da eine Spannung von 16,2V.

Was müsste ich denn für einen Treiber hernehmen, damit das ganze nach möglichkeit auf 12V oder 24V läuft? Könnt ihr einen guten Treiber nebst Lib empfehlen?

Den 12V Motor mußt Du mit einen Spannungstreber betreiben und dadurch hast Du keine Microschritte (zB einen L293D)

Wenn Du Microschritte brauchst dann brauchst Du einen anderen Motor mit kleinerer Nennspannung (und daraus resultierender größerem Nannstrom) und wahrsscheinlich auch einen anderen Treiber weil dieser den Stromerfordernissen des Motors nicht gerecht werden wird.

Grüße Uwe

wäre das ein solcher treiber für den motor?
oder aber kannst du mir einen für den motor empfehlen, der aber nicht das ganze board abdeckt, da ja noch einige schalter dran sollen?

gruß

sebastian