Eclipse C++ Arduino Plugin is acting up

Hello, everyone! I'll try to make this quick and simple. The official Arduino IDE was getting a bit stale for me, so I decided to get the Eclipse C++ plugin for Arduino development. I'd be perfectly happy with it, if it weren't for one tiny, yet annoying, thing.

It uploaded on my Arduino Uno, but not my Nanos, 2 of which I've tried. Attempting to build and upload on a Nano throws the classic:

avrdude: stk500_getsync() attempt XX of XX: not in sync: resp=0xd0

So far, this has only happened with my Nano, and the Uno worked wonderfully.
Could someone guide me as to what could be going on here?

(EDIT NOTE: Yes, I did go to the official IDE with my Nano for this, to discover it worked fine there)

I have no idea about the plugin. The most common issue nowadays for Nano upload errors is the use of 328P vs 328P (old bootloader).

In the IDE, it's under tools -> processor. Any option like that with the Eclips plugin?

Thank you, this is what fixed it for me