Editing nets in Eagle

Maybe I'm just blind to it, but I accidentally joined two nets that should be independent and I can't find any way to break them apart. Is there no function to directly edit which nets are joined to which others?

How did you join them, you mean they occupy the same space on the board and short together? You can move the edges with the move tool (using the ripup tool to make them visible will make this easier). I've also drawn lines on the tRestric/bRestrict layers to make cutouts in them. This usually makes DRC complain, but it works well anyway.

I was rearranging the functions of some header pins in the schematic and went to reassign the VIN pin to RESET, Eagle asked me if I wanted to connect the RESET net with the VIN net and because I was tired and not paying enough attention I clicked Yes. Now as I work on the board layout it keeps drawing a ratline between RESET and VIN. So the problem is in Eagle’s concept of what should be connected to what rather than in anything I’ve drawn which is why I can’t figure out how to fix it. It seems to me like it’d be a serious shortcoming to not have any facility to view & edit the net list.

Oh, I see now. If you had clicked no, it would have cancelled the operation, so yes should have been the correct response. What you may have done is chosen "every segment on this sheet" instead of "this segment" when renaming it. If this is the case, you will have to select each segment that is supposed to be vin and rename it again (being sure to choose "this segment").

There's probably a better way, but a couple of times I've had to just use the replace function to replace a part with itself in order to get rid of an unwanted connection. Not pretty, but it works.

It seems the solution was to delete every segment attached to the relevant nets and rewire the affected pins. It seems that Eagle forgets a net name once all its segments have been deleted. Still wish there were a better way, but if there is I can't for the life of me find it.

Having trouble figuring out why this was such a problem…

I opened Eagle, went into the schematic editor and made two nets named VIN and RESET. Then I drew a net between them, and it asked if I wanted to join them, and what name the resulting net should be. Then, I selected the Delete tool and removed the joining net segment. I still had a VIN net connected to RESET, but all I had to do was rename that net to RESET.

Of course I didn’t have any other components in the schematic. But that’s how I would expect it to work in any case.

Edit: I tried it again with some components, and routed the connections on the PCB. But when I went back into the schematic and deleted the connecting net segment, it worked just like before…the nets were broken apart with no problems.

Could you perhaps have not been using the schematic editor to manage your nets?

In my experience, as long as there was still something assigned to each net somewhere in the schematic eagle was remembering that those nets were supposed to be connected (apparently). Hence why I had to delete all of those segments to make it forget the association; deleting just the misassigned segment was not enough. The problem originated with a stub wire that was assigned by name to the wrong net, not with an errant wire between two components. And since both nets were already wired to multiple components, simply renaming one into the other was not a solution.