Editor not loading code from Cloud

I’m creating a new project in the Arduino Cloud, and when I click the Code button to open the Editor, the editor the editor recognizes the board I have connected and sees the Cloud project (in the dropdown), but it won’t open the code (as shown in the attachment). I can create new files, and the editor opens with the code, but NOT anything that comes from the cloud side.

I’m running the latest Chrome on Windows 10 64 with no pop-up blockers active.

Hello, john. How did you create the sketch in the first place? Was it an empty sketch or one you uploaded from your computer?

Should be working now, by the way

Neither, it’s generated code from Cloud.

As a quick work around you can copy and paste the sketch into a blank sketch in the editor.

Make sure that you save it and also make sure that you see the "saved" message.

Yeah, thanks. I knew I could do that, but I thought the team would like to know this is broken.

I've tried this on Chrome and Firefox on Windows 10, and Chrome on macOS, and it's just not working.

I am not able to upload a sketch now either. The sketch worked fine a few days ago, and it works fine from the desktop IDE. It compiles but gets stuck at the "Flashing with command..." step and then eventually I get 10 attempts of:

avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xf9

I've tried restarting the Create Agent plugin and restarting the browser. No go.

@cgorton1313

Is this a CLOUD issue or a CREATE issue ?
They are two different things.

I may be in the wrong place, although this topic is under Create > Editor. I guess I'll start a new thread, as my problem is not uploading to my board.