EEPROM with Blynk

i could not apply EEPROM to my Blynk code.
when i tried it just made thing worst can someone help me that will be great.
i want to save the led state even if there is a power outage
shastom=led just for you to know

#include <SPI.h>
#include <Ethernet.h>
#include <BlynkSimpleEthernet.h>

char auth = " d12bdb51cbf4453b85675aad7e123ba2";
WidgetLED shastom(V1);
WidgetLED shastom1(V1);
WidgetLED shastom2(V1);
WidgetLED shastom3(V1);
WidgetLED shastom4(V1);
WidgetLED shastom5(V1);
WidgetLED shastom6(V1);
WidgetLED shastom7(V1);

void setup() {
Serial.begin(9600);
Blynk.begin(auth);

pinMode (2,OUTPUT);
pinMode (3,OUTPUT);
pinMode (4,OUTPUT);
pinMode (5,OUTPUT);
pinMode (6,OUTPUT);
pinMode (7,OUTPUT);
pinMode (8,OUTPUT);
pinMode (9,OUTPUT);

}

void loop() {

Blynk.run();
}

shastomim.ino.ino (604 Bytes)

I am familiar with Blynk, but to me your code makes no sense. You have 8 led widgets on your app but they are all controlled by the same virtual pin. I don’t know what that will do. You have made 8 Arduino pins outputs, but then you do nothing with them.

So the are no states to save to EEPROM.

I think you are trying to run before you can walk. Go back to basics.

Before you post again, read the forum guidelines in the sticky post. Then you will know how to post code and other things you must do to allow anyone on the forum to help you.

Please use code tags (</> button on the toolbar) when you post code or warning/error messages. The reason is that the forum software can interpret parts of your code as markup, leading to confusion, wasted time, and a reduced chance for you to get help with your problem. This will also make it easier to read your code and to copy it to the IDE or editor. If your browser doesn’t show the posting toolbar then you can just manually add the code tags:

[code]

[color=blue]// your code is here[/color]

[/code]

Using code tags and other important information is explained in the How to use this forum post. Please read it.

Please remove unnecessary blank lines from your code before posting to the forum. One or two to separate code into logical sections is fine but large spaces for no reason or random blank lines just make for more scrolling when we’re trying to read your code.

When your code requires a library that’s not included with the Arduino IDE please always post a link (using the chain link icon on the toolbar to make it clickable) to where you downloaded that library from or if you installed it using Library Manger(Sketch > Include Library > Manage Libraries) then say so and state the full name of the library.

itay5731:
when i tried it

What did you try? Post your best attempt at it.

itay5731:
it just made thing worst

Please describe exactly what happened.