Eggbot aka Spherebot with bipolar 28BYJ-48 and Inkscape

Hello, I hacked the 28BYJ-48 to bipolar, connected everything to a Protoneer-CNC shield with A4988 set to 200mV. Works, somehow... I have tried GitHub-Yura80/Eggduino and assigned all pins correctly. I have also tried full-stepping, half-stepping and 1/16th stepping (setting MS0-MS1-MS2 jumpers on the board and changing values in eggduino.ino). In Inkscape with eggboat-extension 2.5.0 I've set values for "speed" on values 50-100-250-500-1000 and tried manual control. Loading a testpattern, I hit the button. Servo works fine, but the motors don't. Has anybody ever tried to build a simple eggbot with bipolar 28BYJ-48 steppers? Any hint would be appreciated. Is there different firmware out there I could try? Thank you very much.

Hi, Have you loaded code to just power the stepper to see if it works?

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

Please read the first post in any forum entitled how to use this forum. http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code. It will be formatted in a scrolling window that makes it easier to read.

Thanks.. Tom... :)

There is no "circuit" to draw: Arduino Uno + Protoneer-CNC-Shield + 2x A4988 driver I uploaded grbl and tested the steppers, they are working fine (and surprisingly rather "fast"). I tried Inkscape 0.91 on my Ubuntu-Linux with EggBot 2.5 and 2.7.1 without success. I don't know why. So maybe I should try and get grbl running with the z-axis modified to controll the servo going up/down for the drawing pen.

Or maybe someone knows a different software to run an eggbot?