El Capitan - Arduino IDE serial port problems

:slight_smile: :slight_smile:

Great news ! I have found a solution that’s work perfectly on Mac OS X El Capitan (10.11) !

As I my uploads worked fine on Arduino Pro Mini with my FTDI breakboard and suitable Apple Signed driver , I have tried to use it with Arduino Uno, but it didn’t work …
After long reads in forums and several try, I have finally found the solution that’s work perfectly !

You have to use an FTDI breakboard (Sparkfun) in replacement of built-in Atmega USB chip.

Once you have an FTDI breakboard, download driver :
http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_3.dmg

Step 1: Install Driver
=>Once done, and break board connected to your Mac, you will show “FT232R USB UART” in detailled system information, under USB

Step 2 : Wiring (BB = Breakboard)
BB GND to Arduino GND
BB VCC to Arduino VCC
BB TX0 to Arduino RXD
BB RXI to Arduino TXD
and the last most special wiring => BB DTR to Arduino Reset with 100nF capacitor between DTR pin and Reset pin (In my case, it didn’t work, but with an additional 100nF capacitor to reach 200nF, it works fine !!)

Step 3 : Arduino IDE
Select >Tools > Port: "/dev/cu.usbserialA700e5Q6

Step4 : Upload as usual … and have fun

Capture d’écran 2016-03-12 à 18.04.40.png

Capture d’écran 2016-03-12 à 18.01.36.png

Thank you FrktLille !!

That work perfectly on mac.

So, even though there are success stories, a solution for the new MKR1000 ('Maker One?') for use in OS X El Capitan seems not at hand. I've tried the solution to disable the 'check for signed drivers' to no avail. Tried removing drivers, downloaded the hourly build, but no success.

Anyone here who got an Genuino (or Arduino for that matter) MKR1000 working under OS X 10.11.3 El Capitan?

Do we know what drivers (what chip brand) the MKR1000 needs? Are these signed?

I had trouble with OSX 10.11 and MKR1000. I connected the MKR1000 to another Macbook running 10.9 and loaded the getting started sketch. Once I did that I was able to plug the device back into my 10.11 device running EL Capitan and the port appeared. I don’t understand why.

About MKR1000,

In my opinion, you should be able use the given solution with ftdi breakout board on MKR1000 too, using the MKR1000 following pins : GND : 11 5V : 14 TX : 9 RX : 8 Reset : 10

Actually, I think this solution can be used on all arduino boards ...

I was fighting with this on a new Ada fruit Huzzah ESP8266 board. I installed their USB driver, or thought i had, since its a Kext I needed to do the restart option-r csrutil -disable thing and then reinstall it.

For a while now I had also had some issues with my Arduino Mega only being recognized on one of my two physical USB ports and just been too lazy to investigate since it was easier just to plug in to the 'back' port not the 'front'. As part of fussing with the Huzzah driver I noticed and UNINSTALLED (aka deleted) an OLD FTDI USB Kext I must have put in before upgrading to El Capitan.

That seemed to simultaneously fix both my front USB port with the Arduino Mega and allow the Huzzah to work on either port! and here I thought driver/extension incompatibility issues were dead :) now... to do carve out some time to actually make something before someone upgrades something!

posting in the hope that my random experience helps someone else struggling with this issue.

braines:
As part of fussing with the Huzzah driver I noticed and UNINSTALLED (aka deleted) an OLD FTDI USB Kext I must have put in before upgrading to El Capitan.

how did you go about doing this? I suspect I have the same situation.

thanks
mark.

Hi, How could I add usbport1411 to my mac, at the moment it is working with wchusb1420 which is not compatible with "Arduino Leonardo". Thank you

My arduino have been worked OK under EI Capitan (don't ask me how) But two days ago I moved to brand new Sierra Mac OS and got system halting during inserted USB cable (( Two days of attempting different drivers haven't gave any result.

Finally I got the cure and now it works good (no halts or hang and Arduino SDK 1.6.3 sees port /dev/tty.wchusbserial1420)

(most importan I think were the command sudo rm -rf /System/Library/Extensions/usb.kext as it is despite any reasons (i.e. I hadn't see this "usb.kext" but possibly it was hidden)

Worked for me:

Reboot and press CMD+R immediately after hearing the startup sound to boot to Recovery Mode Open Terminal Execute the following command: csrutil enable --without kext Reboot

Install the following driver:

https://github.com/Makeblock-official/Makeblock-USB-Driver/blob/master/CH34x_Install.zip

I have the same problem with Arduino IDE 1.8.0 (new this week) and a Node MCU1.0. No idea why had to use my Win 7 PC which is a nonsense.

Hi, I tried everyone of these solutions, but none of them worked. But I found that there is a sure way to get rid of this problem. Dual-boot macOS/OS X [insert your os name here] and OS X Yosemite. And since the Yosemite installer is still up on the app store, you can just download it and make a bootable flash drive, then partition your drive to accommodate the new OS and just restart while holding Alt and then boot of the USB drive and then hit re-install or install OS X. But this is kind of a last thing I would try since it's not very fun to switch between OSes when you want to use arduino, but hey, it works.