Elegoo Nano clone showing up as Audio/MIDI device

I was trying to download driver software to the Elegoo nano clone (downloaded from their site, driver for the CH340). I have done it successfully once before, but when i attempted to do it again on a different board, it showed up as a Audio/MIDI device rather than a COM port device. Due to this I cant upload the driver software because it thinks it is an incompatible driver? :frowning: Lots of frustration and many attempts to change driver software through device manager. I have tried selecting a different driver, disabling driver signature to forcefully change it and deleting the device and starting over. None have worked. Anybody have any ideas?

(deleted)

After connecting a few more of their boards to the computer with flawless driver updates, i have come to the conclusion it was probably just a faulty CH340 on the board. I dont think i am going to bother contacting Elegoo because the product is so cheap it isnt worth my time, but thank you for the reply anyway!