Elegoo smart robot car kit v1.0

My issue is the motors aren't turning. I've checked my wiring between the L298N motor driver and the motor shield attached to the Uno like 50 times but still no luck. I've tried re-wiring many times just in case I somehow missed something, but I just can't get it to work.

My guess is that there is an issue with the L298N since I'm using the code and wiring diagram from the CD that came in the box.

What do you think is causing this problem? Thank you for any help you can give.

(deleted)

I don’t have an “Elegoo smart robot car kit v1.0” or “the CD that came in the box” so I’m afraid I don’t know what you’re talking about.

My guess is either the code or the wiring diagram are wrong or you’re powering it incorrectly.

Steve

spycatcher2k:
So you buy a commercial product from Elegoo and expect free support here? Surely you can work out that this is not the Elegoo support forum! So we have NO IDEA what you are talking about!

Post your code.

Post YOUR wiring (Take an in focus, close up picture or 2)

Don't assume anyone can see what is wrong, it's up to YOU to provide the details.

Yes, I can work out that this is not the elegoo support forum. But, this is literally an Arduino with a motor driver board and 4 motors. You don't need to be on the elegoo support forum to know what I'm talking about here when I say the parts I'm using, especially since their all parts everyone in this thread should have encountered at some point. This question was directed at anyone who has used this and has dealt with a similar issue or used an L298N motor driver board and can supply some help, so if you have "NO IDEA" what I'm talking about, then don't respond.

(deleted)