ENC28J60 Not connecting. Help please.

Hello intelligent helpful people,

I thought I'd surprise my daughter with a tweet activated candy machine for Halloween like the ones you see all over Instructables. I've been trying to get my arduino to connect to the net for 3 weeks now to no avail. I've read and tried a several of the solutions I found in this forum and while they seem to have worked for others, I must be missing something. My experience with arduino thus far is limited to successfully making several LED's blink. This is my first attempt at networking.

This is what I am working with.: Gizduino ATMEGA 328 Rev4.0 ENC28J60 Ethernet Shield v1.1 (driver installed) Zyxel DSL Router IDE v1.05 on Win7

I've tried this with my ip values but the serial monitor remains blank http://forum.arduino.cc//index.php?topic=193384.0

I tried this: http://forum.arduino.cc/index.php?topic=183301.0 and I got this: Better client test 12/01/11 Send an e in serial monitor to test connection failed

disconnecting.

Most of the time the serial monitor just prints "connecting...." and stays that way or remains blank.

This is what I get with ipconfig:

Connection-specific DNS Suffix: Description: Realtek PCIe GBE Family Controller Physical Address: ?8C-89-A5-06-75-47 DHCP Enabled: Yes IPv4 Address: 192.168.0.100 IPv4 Subnet Mask: 255.255.255.0 Lease Obtained: Wednesday, October 16, 2013 12:30:55 AM Lease Expires: Wednesday, October 23, 2013 9:56:25 AM IPv4 Default Gateway: 192.168.0.1 IPv4 DHCP Server: 192.168.0.1 IPv4 DNS Server: 192.168.0.1 IPv4 WINS Server: NetBIOS over Tcpip Enabled: Yes Link-local IPv6 Address: fe80::b929:101f:6258:b56e%11 IPv6 Default Gateway: IPv6 DNS Server:

Thank you for your help.

Cheers!

It seems you are using the original Arduino-Ethernet-library which is not compatible with ENC28J60. Get the UIPEthernet-library from https://github.com/ntruchsess/arduino_uip as a plug-in replacement that works with this chip.

  • Norbert