Entire arduino core modules being rebuilt with every compile

I'm having a strange problem with my arduino IDE (1.6.5, but is reproducible on different IDE versions) with an Arduino Uno - after upgrading to Windows 10. Trying to compile and upload any sketch causes the IDE to begin rebuilding all of the core arduino files. The output with verbose compilation enabled is available at:

this is very slow, the 'blink' example sketch (output shown in the pastebin above) takes about 5 minutes to compile and upload. but does upload and run fine on the board.

I have searched for others that have had similar problems, but nobody has posted solutions, or have found bugs which have since been fixed. i'm really unsure why this is happening when i haven't experienced problems with the IDE prior to upgrading from Windows 8.1 to Windows 10. I'm surprised nobody else has had similar issues recently.
Thanks in advance

I am using win 10 but I don't have your problem. Did you install your IDE with the installer or the zip file? I used the zip. A lot less to go wrong with zip version. Installer installs in program files and sometimes file access issues may occur.

I only get this with my Due's, Don't get it with Mega ADK's or Trinket. Windows 10, windows install. Added Adafruit and SAM. Check your preferences.

Thanks for the replies, this seems to happen with every version of arduino IDE i use, i tried a ZIP download of the latest hourly build, a ZIP download of arduino 1.0.6. I have uninstalled version 1.6.5 and tried other versions without success. All preferences have been left to their default values