Erreur de compilation pour la carte Arduino Duemilanove or Diecimila

bonjour à tous, j'ai ce genre de problème, mais malgré l’affichage détailles et mes différentes recherche sur le net, je ne trouve pas la réponse à mon problème, voici le code erreur, si une personne a une idée ?

Arduino : 1.8.2 (Windows 7), Carte : "Arduino Duemilanove or Diecimila, ATmega328P"

C:\Users\admin\AppData\Local\Temp\arduino_build_505671\sketch\TemperatureDHTHorlogeVoltmetreVentilloalarme11.ino.cpp" -o "C:\Users\admin\AppData\Local\Temp\arduino_build_505671\preproc\ctags_target_for_gcc_minus_e.cpp"
open NUL: Le fichier spécifié est introuvable.
Erreur de compilation pour la carte Arduino Duemilanove or Diecimila

merci pour votre réponse

C'est assez clair : ton code fait référence à un fichier (ctags_target_for_gcc_minus_e.cpp) que le compilateur ne trouve pas. Essaye d'effacer le répertoire C:\Users\admin\AppData\Local\Temp\arduino_build_505671\ puise recommence...

merci pour ta réponse,, je vais essayer, je debute en arduino, donc je ne vois pas tous les problèmes !

rien a faire !!

"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\NexObject.cpp" -o "nul"
"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\NexPage.cpp" -o "nul"
"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\NexPicture.cpp" -o "nul"
"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\NexProgressBar.cpp" -o "nul"
"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\NexSlider.cpp" -o "nul"
"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\NexText.cpp" -o "nul"
"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\NexTouch.cpp" -o "nul"
"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\NexWaveform.cpp" -o "nul"
Generating function prototypes...
"C:\Users\admin\AppData\Local\Arduino15\packages\arduino\tools\avr-gcc\5.4.0-atmel3.6.1-arduino2/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10802 -DARDUINO_AVR_DUEMILANOVE -DARDUINO_ARCH_AVR "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\cores\arduino" "-IC:\Users\admin\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.23\variants\standard" "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\sketch\TemperatureDHTHorlogeVoltmetreVentilloalarme11.ino.cpp" -o "C:\Users\admin\AppData\Local\Temp\arduino_build_624194\preproc\ctags_target_for_gcc_minus_e.cpp"
open NUL: Le fichier spécifié est introuvable.
Erreur de compilation pour la carte Arduino Duemilanove or Diecimila

effectivement le dossier:
C:\Users\admin\AppData\Local\Temp\arduino_build_624194\preproc\ctags_target_for_gcc_minus_e.cpp"

est vide,mémé après avoir efface le dossier, il manque toujours un dossier

"C:\Users\admin\AppData\Local\Temp\arduino_build_613032\preproc\ctags_target_for_gcc_minus_e.cpp"
open NUL: Le fichier spécifié est introuvable.

donc c'est ce fameux dossier :ctags_target_for_gcc_minus_e.cpp qu'il me manque !!

avez vous une idée ??

Merci

"C:\Users\admin\AppData\Local\Temp\arduino_build_613032\preproc\ctags_target_for_gcc_minus_e.cpp"
open NUL: Le fichier spécifié est introuvable.

Si tu observes bien le fichier ctags_target_for_gcc_minus_e.cpp est situé dans un répertoire Temp de ton répertoire personnel.
C'est l'IDE qui crée le sous répertoire arduino_build_613032. Un sous-répertoire par projet.
Ces sous-répertoires sont virés quand tu quittes l'IDE, et recréés lors de la prochaine compilation.

Ce qui me choque dans ton cas c'est que ton répertoire personnel s'appelle admin.
J'ai divorcé de Windows il y a dix ans, je connais mal ce système, mais je trouve cela bizarre, à moins que ce soit ton vrai identifiant de login.
Vérifie que tu as les droits en écriture dans le répertoire C:\Users\admin\AppData\Local\Temp en y copiant un fichier quelconque.

@+

Bonjour, malgré toutes mes tentatives , vérification des droits en écriture, désactivation du par-feu,installation d'une autre version du log arduino, toujours rien !!!

quel galère !!!

Essaye de désinstaller l’ide arduino et d’installer la version 1.8.5

déjà fait, mais merci du conseil

Tout ce que je peux te dire est que le fichier ctags_target_for_gcc_minus_e.cpp est généré par le préprocesseur dans le répertoire preproc.
Essaie de compiler pour une MEGA ou une autre carte, juste pour voir si tu rencontres le même problème.

@+

j'ai fait un essai pour différentes carte, aucun résultats, meme avec un exemple fourni avec le log arduino !!!!

aucun résultats

Tu veux dire : aucune erreur ou résultat négatif ?

résultat négatif, toujours la même erreur !!

Est-ce que ça a marché avant ? Si oui, qu’as-tu fait juste avant que ça tombe en panne ?
Si réinstaller l’IDE ne solutionne pas le problème (quelles versions as-tu testé ? Moi j’ai la 1.8.2) c’est peut-être un problème de Java ?

oui , ça marcher très bien avant, juste un je n'ai pas toucher à l'ordi pendant 2 mois ( travaux garage donc très occupé), et la reprise du programme pour changer un paramètre température , et au moment de téléverser erreur !!!, re-changement du paramètre température au cas ou , mais rien a faire !!, donc essai avec un exemple, rien a faire, changement de l'IDE, ancien ( 1.8.5 ) pour repasser au 1.8.2, rien a faire, mais essayer de repasser avec un version 1.6, mais toujours rien a faire !!!

reste a voir java , cela pourrais être lui le coupable ?

Je ne sais pas, c'est juste une idée comme ça. Sinon, c'est ton ordi qui est susceptible et mécontent d'avoir été abandonné pendant 2 mois...

voila une bonne raison pour passer sous linux :slight_smile:

Un problème d'anti-virus ?
Tu as essayé de le désactiver ?
Ou alors égorger un poulet ? Avec Windows quelques fois ça marche. ;D

voila une bonne raison pour passer sous linux :slight_smile:

Oui, mais tu perdrait le côté magique de Windows. Je veux parler du côté magie noire.

@+

ou magie bleue, c'est selon...

encore qu'avec les versions récentes, l'écran bleu se fait rare :stuck_out_tongue:

Vrai.

Pour en revenir au problème, c'est comme si le préprocesseur (avr-cpp) ne faisait rien.
Il faudrait ouvrir un terminal dans le répertoire où se trouves les binaires avr : hardware/tools/avr/bin
Vérifier l'existence de avr-cpp.
Lancer : avr-cpp --help

@+