erreur de televersment

Bonjour,

Jusqu’ici j’ai été largement satisfait de ma carte Arduino Mega 2560 mais d’un coup lors d’un televersement elle m’a planté au milieu du cycle d’écriture (Writting Flash).

extrait du journal :

"avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is “C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf”

Using Port : COM3
Using Programmer : wiring
Overriding Baud Rate : 115200
AVR Part : ATmega2560
Chip Erase delay : 9000 us
PAGEL : PD7
BS2 : PA0
RESET disposition : dedicated
RETRY pulse : SCK
serial program mode : yes
parallel program mode : yes
Timeout : 200
StabDelay : 100
CmdexeDelay : 25
SyncLoops : 32
ByteDelay : 0
PollIndex : 3
PollValue : 0x53
Memory Detail :

Block Poll Page Polled
Memory Type Mode Delay Size Indx Paged Size Size #Pages MinW MaxW ReadBack


eeprom 65 10 8 0 no 4096 8 0 9000 9000 0x00 0x00
flash 65 10 256 0 yes 262144 256 1024 4500 4500 0x00 0x00
lfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
hfuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
efuse 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
lock 0 0 0 0 no 1 0 0 9000 9000 0x00 0x00
calibration 0 0 0 0 no 1 0 0 0 0 0x00 0x00
signature 0 0 0 0 no 3 0 0 0 0 0x00 0x00

Programmer Type : Wiring
Description : Wiring
Programmer Model: AVRISP
Hardware Version: 15
Firmware Version Master : 2.10
Vtarget : 0.0 V
SCK period : 43.5 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude: Device signature = 0x1e9801
avrdude: reading input file “C:\Users\SULERF~1\AppData\Local\Temp\buildc6a90edf384f5b02fb01e9467f1117d5.tmp/acceuil_arduino_lcd_PI.ino.hex”
avrdude: writing flash (2856 bytes):

**Writing | #############################################**avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer"

si vous avez des suggestions . Pour ma part j’ai déjà désinstallé et réinstallé les drivers, essayé tout mes ports USB en essayant 3 câbles différents

Dans l’éspèrence d’une solution,

François S.

(PS : C’est la carte de mon prof de Science Ingénieur alors j’ai plutôt intérêt a la remettre en route)

bonjour, suggestion 1 remettre en noir le texte, illisible en orange. merci

Salut , j'ai eu ce problème ... suite à une réinstallation du programme , c'était un driver non installé par mon o.s. .

je viens de tester avec une NANO et l'upload se fait sans aucun probleme

salut , c'est peu être un plantage du à l'environnement java . Il parait que ça arrive de temps en temps (j'ai vu ça sur un tutoriel), suffit de refaire le téléversement .

malheureusement c'est quelque-chose qui arrive a chaque fois

fjs57:
malheureusement c’est quelque-chose qui arrive a chaque fois

bonsoir
c’est un Arduino mega “officiel” avec l’interface UART/USB basée sur un 16U2 (ou 8U2) ?
ou un clone ?

officiel prêté par mon prof de science ingénieur

en sur la puce : ATMega 2560 16AU et l

Si le premier circuit intégré (le plus petit à gauche de la carte près de la prise USB) est un atmega 16U2 tu peux dire à ton professeur : "Maladie classique des Atmega16U2". Les clones avec un CH340G sont plus fiables.

68tjs: Si le premier circuit intégré (le plus petit à gauche de la carte près de la prise USB) est un atmega 16U2 tu peux dire à ton professeur : "Maladie classique des Atmega16U2". Les clones avec un CH340G sont plus fiables.

bonjour je n'ai jamais compris ce qui a poussé l'equipe arduino à coller du 8U2 ou du 16U2 ayant pour seul but de faire de la conversion USB/Serial en remplacement du FTDI (Duemilanove par exemple)

Bonsoir, Ils doublaient le nombre de circuit achetés et Atmel leur a fait une ristourne : ce n'est qu'une affaire de pognon. FTDI devait aussi abuser sur les prix vu que c'est leur seul produit qui a réellement eu du succés.

Heureusement les p'tits chinois ne se laissent plus prendre et ils sont revenus a des circuits dédiés USB/UART.

donc une solution ?

Reflasher le logiciel de l'atmega 16U2 --> ça peut (ou pas) remettre les choses dans l'ordre --> il faut voir avec ton professeur, c'est lui qui est responsable de la carte.

Attention c'est une procédure spéciale : de la documentation existe. Un conseil : ne perd pas ton temps avec cela, c'est une maladie chronique des Atmega16u2, demande une autre carte.