Erreur mega or mega 2560

Bonjour,

J’ai un problème de compilation, cela fonctionnait encore ce matin même.
C’est un problème avec la librairie u8g qui pourtant à été ajoutée.

Merci d’avance

C:\Users\le-br\OneDrive\Documents\Arduino\libraries\U8glib_Arduino-master\src\clib\u8g_rect.c: In function 'u8g_DrawBox.constprop':

C:\Users\le-br\OneDrive\Documents\Arduino\libraries\U8glib_Arduino-master\src\clib\u8g_rect.c:126:1: internal compiler error: Segmentation fault

 }

 ^

Please submit a full bug report,

with preprocessed source if appropriate.

See <http://gcc.gnu.org/bugs.html> for instructions.

lto-wrapper.exe: fatal error: C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avr-gcc returned 1 exit status

compilation terminated.

c:/program files/windowsapps/arduinollc.arduinoide_1.8.21.0_x86__mdqgnx93n4wtt/hardware/tools/avr/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld.exe: error: lto-wrapper failed

collect2.exe: error: ld returned 1 exit status

Utilisation de la bibliothèque U8glib_Arduino-master version 1.19.1 dans le dossier: C:\Users\le-br\OneDrive\Documents\Arduino\libraries\U8glib_Arduino-master 
exit status 1
Erreur de compilation pour la carte Arduino/Genuino Mega or Mega 2560

pour éliminer tout problème de votre code, si vous testez avec un des exemple u8g, voyez vous le même comportement?

quelle version de l'IDE ? l'avez vous mis à jour ?

est-ce que la libraire est bien installée ? (virez là et réinstallez la)

J’ai la version 1.8.9

Je viens de désinstaller/réinstaller la librairie et j’ai le même message d’erreur

pour éliminer tout problème de votre code, si vous testez avec un des exemple u8g, voyez vous le même comportement?
la carte choisie est bien la MEGA pour le compilo ?

Je n'utilises pas windows mais ce nom de chemin me semble bizarre.

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.21.0_x86__mdqgnx93n4wtt

Il fait référence à un numéro de version de l'IDE qui m'est inconnu.
Tu l'as trouvé où ta version de l'IDE?

Bonjour,

Si tu as téléchargé la version sur le windows store, télécharges la version sur le site arduino car pas mal de personnes ont des problèmes avec la version sur windows store.

ArduinoIDE_1.8.21

Windows toujours en avance sur son temps :smiling_imp:
1.8.21 n'existe pas.

Segmentation fault

La librairie n'est pas en cause. Le compilateur plante, tout simplement.
Réinstalle une version officielle : 1.8.8, 1.8.10 comme dit kamill.