Erro Compilação "Esperando ";"" [RESOLVIDO]

Olá, Boa noite, estou fazendo um projeto para a faculdade, onde o objetivo é criar um “jogo genios ou simon”, já não bastando a dificuldade de elaborar, estou programando “estruturado”, ou seja usando abas para cada bloco de função, e o meu programa acusa a falta de um “;” no trecho do código. Porém ele existe lá, sim… alguém pode me ajudar?
Segue o Código, da onde ele acusa a falta de “;”.

// ----------------------------------------- declaração das variaveis e loop:

int buzzer = 3;

int led_red = 4;
int led_yellow = 5;
int led_green = 6;
int led_blue = 7;

int botao_1 = 8;
int botao_2 = 9;
int botao_3 = 10;
int botao_4 = 11;

int sequencia[10] = {};

int posicao_rodada = 1;

int rodada = 0;

int resposta_botao = 0;

void setup() {

  pinMode (buzzer, OUTPUT);

  pinMode (led_red, OUTPUT);
  pinMode (led_yellow, OUTPUT);
  pinMode (led_green, OUTPUT);
  pinMode (led_blue, OUTPUT);

  pinMode (botao_1, INPUT);
  pinMode (botao_2, INPUT);
  pinMode (botao_3, INPUT);
  pinMode (botao_4, INPUT);

  randomSeed(analogRead(0));
}

void loop() {
  do {
    if (rodada == 0) {
      pisca();
      delay(100);
      pause();
      rodada ++;
    }
    delay(100);

    funcao_randomica ();
    espera_jogada ();
    rodada++
  } while (rodada <= 10);
}

//------------------------------------------   declaracao para piscar os leds, numa determinada parte do projeto...
void pisca_red () {
  digitalWrite (led_red, HIGH);
  sound_red (led_red);
  digitalWrite (led_yellow, LOW);
  digitalWrite (led_green, LOW);
  digitalWrite (led_blue, LOW);
  digitalWrite (led_red, LOW);
}

void pisca_yellow () {
  digitalWrite (led_yellow, HIGH);
  sound_yellow (led_yellow);
  digitalWrite (led_green, LOW);
  digitalWrite (led_blue, LOW);
}

void pisca_green () {
  digitalWrite (led_red, LOW);
  digitalWrite (led_yellow, LOW);
  digitalWrite (led_green, HIGH);
  sound_green (led_green);
  digitalWrite (led_blue, LOW);
}

void pisca_blue () {
  digitalWrite (led_red, LOW);
  digitalWrite (led_yellow, LOW);
  digitalWrite (led_green, LOW);
  digitalWrite (led_blue, HIGH);
  sound_blue (led_blue);
}

E por mais que comente a linha, para ver se sai o erro, ele continua acusando a falta de “;” na última linha aonde tem :“sound_blue (led_blue);”

******O erro se deu, devido ao fato de usar programação estruturada (por abas), e o erro estava em outra aba, mas na mesma altura do código… ****