Error after upgrading PC

I have a sketch which has been written for the TinyScreen devices, created last year and works fine. It compiled and has been downloaded to a number of units.

The only Includes I have are;
#include <SPI.h>
#include <STBLE.h>
#include “BLEtypes.h”
#include <TinyScreen.h>

The only thing changed since I last downloaded, is that I upgraded my PC from Windows 7 to Windows 10 …

I came to compile and download to a new unit yesterday and I am getting a compile error;

C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\cores\arduino/Uart.h:25:19: fatal error: cstddef: No such file or directory

#include

No changes have been made to the environment nor the sketch itself…

I did discover that a file called cstddef is present within the Microsoft Visual Studio libraries??

Any idea what I can do …or what the problem is?

Phil

Hello Philmonfie

Your report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Please post the complete report.

Regards,
bidouilleelec

Hi bidouilleelec…thanks for interest

Here is the full output; None of the Errors are within my sketch;

Arduino: 1.8.5 (Windows 10), Board: “TinyScreen+, Default”

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Phils\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Phils\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Phils\Documents\Arduino\libraries -fqbn=TinyCircuits:samd:tinyscreen:BuildOption=normal -ide-version=10805 -build-path C:\Users\Phils\AppData\Local\Temp\arduino_build_823510 -warnings=none -build-cache C:\Users\Phils\AppData\Local\Temp\arduino_cache_401244 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0 -prefs=runtime.tools.CMSIS-Atmel.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0 -prefs=runtime.tools.CMSIS.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0 -prefs=runtime.tools.openocd.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\openocd\0.9.0-arduino -verbose C:\PJ Documents\PJ BSM\Vibe\TinyWatch\Sketches\VibeTestwithscreen\VibeScreen1.0\VibeScreen1.0.ino

C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\Phils\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\Phils\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\Phils\Documents\Arduino\libraries -fqbn=TinyCircuits:samd:tinyscreen:BuildOption=normal -ide-version=10805 -build-path C:\Users\Phils\AppData\Local\Temp\arduino_build_823510 -warnings=none -build-cache C:\Users\Phils\AppData\Local\Temp\arduino_cache_401244 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -prefs=runtime.tools.bossac.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0 -prefs=runtime.tools.CMSIS-Atmel.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0 -prefs=runtime.tools.CMSIS.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0 -prefs=runtime.tools.openocd.path=C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\openocd\0.9.0-arduino -verbose C:\PJ Documents\PJ BSM\Vibe\TinyWatch\Sketches\VibeTestwithscreen\VibeScreen1.0\VibeScreen1.0.ino

Using board ‘tinyscreen’ from platform in folder: C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8

Using core ‘arduino’ from platform in folder: C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8

Detecting libraries used…

“C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++” -mcpu=cortex-m0plus -mthumb -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -fno-threadsafe-statics -nostdlib --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -w -x c++ -E -CC -DF_CPU=48000000L -DARDUINO=10805 -DARDUINO_SAMD_ZERO -DARDUINO_ARCH_SAMD -D__SAMD21G18A__ -DUSB_VID=0x03EB -DUSB_PID=0x8009 -DUSBCON ‘-DUSB_MANUFACTURER=“TinyCircuits”’ ‘-DUSB_PRODUCT=“TinyScreen+”’ -DUSBCON “-IC:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0/CMSIS/Include/” “-IC:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0/CMSIS/Device/ATMEL/” “-IC:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\cores\arduino” “-IC:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\variants\tinyscreen_p” “C:\Users\Phils\AppData\Local\Temp\arduino_build_823510\sketch\VibeScreen1.0.ino.cpp” -o “nul”

“C:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++” -mcpu=cortex-m0plus -mthumb -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -fno-threadsafe-statics -nostdlib --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -w -x c++ -E -CC -DF_CPU=48000000L -DARDUINO=10805 -DARDUINO_SAMD_ZERO -DARDUINO_ARCH_SAMD -D__SAMD21G18A__ -DUSB_VID=0x03EB -DUSB_PID=0x8009 -DUSBCON ‘-DUSB_MANUFACTURER=“TinyCircuits”’ ‘-DUSB_PRODUCT=“TinyScreen+”’ -DUSBCON “-IC:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\CMSIS\4.5.0/CMSIS/Include/” “-IC:\Users\Phils\AppData\Local\Arduino15\packages\arduino\tools\CMSIS-Atmel\1.1.0/CMSIS/Device/ATMEL/” “-IC:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\cores\arduino” “-IC:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\variants\tinyscreen_p” “C:\Users\Phils\AppData\Local\Temp\arduino_build_823510\sketch\VibeScreen1.0.ino.cpp” -o “C:\Users\Phils\AppData\Local\Temp\arduino_build_823510\preproc\ctags_target_for_gcc_minus_e.cpp”

In file included from C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\cores\arduino/avr/pgmspace.h:30:0,

from C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\cores\arduino/Arduino.h:36,

from C:\Users\Phils\AppData\Local\Temp\arduino_build_823510\sketch\VibeScreen1.0.ino.cpp:1:

c:\users\phils\appdata\local\arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1\arm-none-eabi\include\inttypes.h:255:5: error: user-defined literal in preprocessor expression

#if PTRDIFF_MAX <= __INTTYPES_EXP(INT_MAX)

^

c:\users\phils\appdata\local\arduino15\packages\arduino\tools\arm-none-eabi-gcc\4.8.3-2014q1\arm-none-eabi\include\inttypes.h:258:7: error: user-defined literal in preprocessor expression

#elif PTRDIFF_MAX <= __INTTYPES_EXP(LONG_MAX) || !defined(__have_longlong64)

^

In file included from C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\variants\tinyscreen_p/variant.h:43:0,

from C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\cores\arduino/delay.h:23,

from C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\cores\arduino/Arduino.h:81,

from C:\Users\Phils\AppData\Local\Temp\arduino_build_823510\sketch\VibeScreen1.0.ino.cpp:1:

C:\Users\Phils\AppData\Local\Arduino15\packages\TinyCircuits\hardware\samd\1.0.8\cores\arduino/Uart.h:25:19: fatal error: cstddef: No such file or directory

#include

^

compilation terminated.

exit status 1
Error compiling for board TinyScreen+.

Welcome to the world of 'Windows' & 'Java', i suspect that in the windows upgrade the path that is being referenced has changed. The easiest is probably to uninstall and re-install the IDE. (if you have any additional boards , you will have to provide the link to their location again and install them again)

Thanks Deva - I have checked and all of my libraries, board definitions etc. are still in the same place. (I have a laptop that I sync to - and have checked).

The only issue I have is that file when compiling.

I think the IDE installation adds a 'path' to your general 'paths' somewhere and this setting may have gotten lost somewhere in the upgrade. Anyway you are not on the latest IDE release anyway, so you could just upgrade to that, and that should fix it.