Error arrays del video tutorial 4 de clases de arduino [SOLUCIONADO]

Hola gente, saludos. Estoy aprendiendo con los videos “clases de arduino” que hay en documentación y creo que he copiado bien todo lo que pone. Pero al ir a verificar me tira un error. ¿Me echais una mano para solucionarlo?

Este es el código del tutoorial:

byte misled[8] = {2,3,4,5,6,7,8,9};                       //para controlar el encendido
byte misledcontrario[8] = {9,8,7,6,5,4,3,2};                   //para controlar el apagado
byte valorjuego1[8] = {1,1,1,1,1,1,1,1};                        //encendido
byte valorjuego2[8] = {0,0,0,0,0,0,0,0};                        //apagado
void setup()
{
   for(int i=0;i<8; 1++) 
{
   pinMode(misled[i],OUTPUT);                                      //depende del contador "i"
 }
 }
void loop()
{
   for(byte i=0;i<8; i++)                                              //primer movimiento
{
  digitalWrite(misled[i],valorjuego1[i]);
  delay(500);
}
  for(byte i=0;i<8; i++)                                             //segundo movimiento
{
  digitalWrite(misledcontrario[i],valorjuego2[i]);
  delay(500);
}
}

Este es el error que sale:

Arduino:1.6.7 (xxxxxxxx), Placa:"Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

/Users/xxxxx/Documents/Arduino/arrays_video/arrays_video.ino: In function 'void setup()':
arrays_video:7: error: lvalue required as increment operand
    for(byte i=0;i<8; 1++) 
                       ^
exit status 1
lvalue required as increment operand

Hola.
Te está señalando directamente al error:

for(byte i=0;i<8; 1++)

debería ser

for(byte i=0;i<8; i++)

Muchas gracias noter. Ahora lo veo... creo que tengo que volver a visitar al oculista, jajaja. Bueno, a seguir con los tutoriales.

Un saludo.