Error: avrdude: stk500_getsync(): not in sync: resp=0x00

I'm using Windows 7 and an Arduino Uno.

I have the latest driver, the right serial port and the right board selected.

I have connected a lego-motor to the arduino and uploaded the sketch to make it run. It worked perfectly. Then I added a second lego-motor, updated the sketch and wanted to upload it, but it didn't work. I got this: avrdude: stk500_getsync(): not in sync: resp=0x00

When I tried shift+upload, I got this: avrdude: usbdev_open(): did not find any USB device "usb"

I also don't seem to be able to use the reset-button.

I have done the loop-back test, and it didn't work. My input was not echoed back correctly.

What kind of troubleshooting equipment do you have (i.e. Spare Arduino, DMM, USBTiny, etc)?

Please see this discussion,28223.0.html

Please see this discussion,28223.0.html

I am afraid that the failed loopback test points to the USB2TTL microcontroller, in this case the 16u2 not the 328/Bootloader. The only thing comparable is to plug the USB in and reset the Mega16u2 but shorting the Reset to Ground on the 16u2 ICSP header:

But I am suspecting a re-flashing of the 16u2 maybe in order.

Ok, just got this thing in the "Getting Started Kit" and I am trying to load a program from the examples (Blinking) for the first time, and I get this error. I verifed the correct port (COM9), I followed the instructions for loading the correct drivers, and I assume it worked becuase everything went as the instructions indicated. Until I tried to follow the load the example instructions and now here I am, underimpressed and frustrated.

I completely unplugged the device and ran the upload process and got the same error.

I then shut down the whole computer, and rebooted. Not working still. The I rebooted with the device attached and the same result.

windows xp,

Do you have any activity on the Rx/Tx LEDs?

none, but the power light is on and there is another one that just keeps blinking as a steady rate.

BTW, i just tried it on a different computer, running W7 and it worked... :~

Driver then... Install this modified Arduino IDE on the unhelpful computer:,118440.0.html

It is actually a very nice variant and it is extremely helpful with troublesome drivers.

Ok. So I tried the link you recommened, and I could not get anything to download from the Mediafire cloud storage site that I was sent to. clicked on download, nothing happened. the the download linik changed to , oops, down lad needs repair. clicked it, nothing. tried this about 10 times with the same results :( Then on the 11th try, I got a big fat warnig from my Norton Virus protection that this download was stopped doue to trying to go to a known malicious web-site.

Help, I just want to use this thing, and now I'm thinking that it will never work. Argggg. I'm very confused.

Quite odd... I just downloaded "setup_Arduino_ERW_1.0.1h_20121002.exe" with no problems. Do you have a pop-up blocker on? If so, just download the 38.05MB file (Don't click on the other crap).

I'm getting the same issues with IDE 1.0.1 ! My solution was to install IDE 0.23 along side 1.0.1 (used for Arduino Mega ADK) And I havn't had the issue!

Well, I've been gone a couple of days because I got a virus when I downloaded from the Metafire site and it took me that long to clean it out. I'm still not sure it's entirely gone. Seems to hijack my google chrome searches.

but the weird thing is, now my xp machine is communicating properly with my Arduino :)

Unfortunately, I'm not sure why it works now.

Must have been a MicroChip Worm :P